Aha
Posts: 64
Joined: Sun Jul 28, 2013 10:58 am

Profile for Taz 6 v3 extruder

Tue Feb 20, 2018 10:55 am

This is a similar post to a subthread. I'd like a Taz 6 v3 print head profile! I started this based on someone else's Taz 5 v3 print head fff file and that post. Anyone that could help me modify this to work would be greatly appreciated. The following bugs definitely need working out, with a few more that will probably come from solving these bugs!

WARNING, it's still NOT complete!

I need some expert help and tuning on it, here are the major errors (aside from the minor ones like oozing):
1. The start gcode improperly dodges the first probe head that is sticking up now because of the addition when installing the v3. Because of this, the tool heads CRASH and GRIND on it at the start of print. I tried adding some lift and dodge code that didn't fix it.
2. The tool heads CRASH and GRIND on the print bed. Z offset is wrong. I finally got it tuned to work in cura and the firmware (now -1.550 vs the original -1.2 and they suggest -1.2 to -1.4, though that could be different per machine I suppose), but S3D doesn't work right with it, not sure why! I was going to just start figuring it out using z offset on the global offset settings in s3d, starting with z offset at +2 and working backwards, but haven't yet.

Note that you need to set your own offsets in the machine control panel. This is left extruder at -6.5 y and right extruder at + 6.5 y. Because of the crashing and grinding I haven't seen if there are any adjustments to that needed (hopefully not, as that might mean I slightly broke my heads)


Minor things needing fixing:
-The start gcode taken from lulzbot cura changes the original retraction of a crazy 45 mm to less - but the retraction and priming needs to be better.
-s3d takes all of the stay hot, warm, etc temps to mean that the temp should be put to full, so the probe temps now jump to 200 (my full on temp atm) and it oozes while probing. A bunch of tiny details could be taken from the official Taz profiles and probably set probing and other temps (interesting that the cura profiles look more to 140, whereas the s3d sets it to 170 and I get some oozing that way).

Any help would be helpful, even if it's to take this profile and build a better one from it, I'd be happy! I'm hating needing to use cura and want to get back to s3d ASAP!!!!!
Attachments
Taz 6 v3 Dual Extruder.fff
Taz 6 v3 dual ext
(38.82 KiB) Downloaded 146 times

b-morgan
Posts: 24
Joined: Tue Oct 24, 2017 11:00 am

Re: Profile for Taz 6 v3 extruder

Sun Mar 18, 2018 9:40 pm

I'm printing a two color 3DBenchy on my TAZ 6 with the Dual V3 toolhead. At the top of the Cura Dual V3 start code I added:

Code: Select all

M218 T0 X0 Y0 ; Simplify3D requires tool offsets in firmware
M218 T1 X0 Y0 ; offset for front extruder (set at end)
and at the end of the Cura Dual V3 start code I added:

Code: Select all

M218 T0 X0 Y0 ; Simplify3D requires tool offsets in firmware
M218 T1 X13.0 Y0.0 ; offset for front extruder
The complete start gcode I'm using (still needs a few more temperature [variables]):

Code: Select all

G26 ; clear probe fail condition
G21                          ; set units to Millimetres
M107 ; Stop the fan
G90                          ; absolute positioning
M218 T0 X0 Y0 ; Simplify3D requires tool offsets in firmware
M218 T1 X0 Y0 ; offset for front extruder (set at end)
M140 S[bed0_temperature] ; start heating bed
M104 S170 T0 ; start heating back extruder
M104 S170 T1 ; start heating front extruder
G28 X Y ; home X and Y
G1 X-17 F3000                ; clear X endstop
G1 Y258 F3000                ; move over the Z_MIN switch
G1 X-19 F3000                ; move left as far as possible
M109 S170 T0 ; soften filament for Z homing
M109 S170 T1 ; soften filament for Z homing
G28 Z ; home Z
T0 ; select this extruder first
M82                          ; set extruder to absolute mode
G92 E0 ; zero extruder
G1 E-12 F100 ; retract 12mm filament
T1 ; switch extruders
M82                          ; set extruder to absolute mode
G92 E0 ; zero extruder
G1 E-12 F100 ; retract 12mm filament
T0 ; switch extruders
G1 X-17 Y100 F3000 ; move above wiper pad
G1 Z1                        ; push nozzle into wiper
G1 X -18 Y95 F1000                   ; slow wipe
G1 X -18 Y90 F1000                   ; slow wipe
G1 X -18 Y85 F1000                   ; slow wipe
G1 X -17 Y90 F1000                   ; slow wipe
G1 X -18 Y80 F1000                   ; slow wipe
G1 X -17 Y95 F1000                   ; slow wipe
G1 X -18 Y75 F2000                   ; fast wipe
G1 X -17 Y65 F2000                   ; fast wipe
G1 X -18 Y70 F2000                   ; fast wipe
G1 X -17 Y60 F2000                   ; fast wipe
G1 X -18 Y55 F2000                   ; fast wipe
G1 X -17 Y50 F2000                   ; fast wipe
G1 X -18 Y40 F2000                   ; fast wipe
G1 X -17 Y45 F2000                   ; fast wipe
G1 X -18 Y35 F2000                   ; fast wipe
G1 X -17 Y40 F2000                   ; fast wipe
G1 X -18 Y70 F2000                   ; fast wipe
G1 X -17 Y30 Z2 F2000                ; fast wipe
G1 X -18 Y35 F2000                   ; fast wipe
G1 X -17 Y25 F2000                   ; fast wipe
G1 X -18 Y30 F2000                   ; fast wipe
G1 X -17 Y25 Z1.5 F1000              ; slow wipe
G1 X -18 Y23 F1000                   ; slow wipe
G1 X -17 Z15                         ; raise extruder
M204 S100 ; set accel for probing
G29 ; probe sequence (for auto-leveling)
M204 S500 ; set accel back to normal
G1 X100 Y-25 Z0.5 F3000      ; move to open space
M400 ; clear buffer
M117 Heating...
M104 S[extruder0_temperature] T0 ; start heating back extruder
M104 S[extruder1_temperature] T1 ; start heating front extruder
M190 S[bed0_temperature] ; stabilize bed
M109 S[extruder0_temperature] T0 ; stabilize back extruder
M109 S[extruder1_temperature] T1 ; stabilize front extruder
M117 Purging...              ; LCD status message
T0                           ; select this extruder first
G1  E0 F100                  ; undo retraction
G92 E-15                     ; set extruder negative amount to purge
G1  E0 F100                  ; purge XXmm of filament
T1                           ; switch to second extruder
G92 E-12                     ; reset global extruder position (from above)
G1  E0 F100                  ; undo retraction
G92 E-15                     ; set extruder negative amount to purge
G1  E0 F100                  ; purge XXmm of filament
G1 Z0.5                      ; clear bed (barely)
G1 X100 Y0 F5000             ; move above bed to shear off filament
T0                           ; switch to first extruder
G1 Z2 E0 F75
M400                         ; clear buffer
M218 T0 X0 Y0 ; Simplify3D requires tool offsets in firmware
M218 T1 X13.0 Y0.0 ; offset for front extruder
M117 TAZ Printing...

While slightly off topic, if anyone knows what to use for Cura's {material_soften_temperature_0}, {material_soften_temperature_1}, {material_wipe_temperature_0}, {material_wipe_temperature_1}, {material_probe_temperature_0}, and {material_bed_temperature_layer_0} I'd be happy to fix the constant 170 temps in the above start gcode.

Return to “Feature Requests”