GBuchwitz
Posts: 10
Joined: Mon Oct 23, 2017 3:18 pm

Recovering Lost Processes

Fri May 04, 2018 5:48 pm

Hi. I've been printing with PETG for awhile and recently decided to experiment with a new filament. I decided it might be a good time to use S3D's Configuration Assistant to see if it could set me up with settings for this filament which were recommended for my particular printer (MakerGear M3-SE).

Immediately afterwards I discovered that I couldn't seem to access any of the process settings I'd created and tweaked over months of working with PETG! Does anyone know how I might be able to regain access to the processes I apparently lost by invoking the Configuration Assistant?

Thanks very much!

V/r, - guy

GBuchwitz
Posts: 10
Joined: Mon Oct 23, 2017 3:18 pm

Re: Recovering Lost Processes

Fri May 04, 2018 7:32 pm

Oops! This is a case of operator error. I didn't realize that using S3D's Configuration Assistant added another profile which - because it contained none of my prior processes couldn't be expected to make them available to me.

V/r, - guy

User avatar
ClintGoss1
Posts: 24
Joined: Tue Apr 10, 2018 9:38 am

Re: Recovering Lost Processes

Sat May 05, 2018 1:22 pm

Regardless of S3D ability to manage profiles, I've run into issues where profiles do get corrupted or wiped out. This has happened on a version update to S3D and another case of a corrupted profile infecting other profiles. In both cases, CS advised me to re-initialize S3D and re-import my profiles. So, I suggest ...

To save your future self from episodes of hair-pulling and teeth-gnashing: Save your profiles outside of S3D using your own backup strategy.

On Windows, S3D keeps all this profile info in the Registry, a notably corruptible resource. To save profiles, you might:

  • Use the File => Export FFF Profile with every printed project (you need to select the correct profile before writing the file). Unless I am using identical settings to a previous print, I'll do this and save it to a file of the name "<ProfileName>_asOfYYYYMMDD.fff", in the same directory as my .STL and/or .GCODE files.
  • Log profile settings and/or changes in a text file. I do this as well, in a shorthand format that looks something like the Brief Profile Display shown below. This is just a tad obsessive, but this process has really helped me tweak profiles rather than just stabbing at them trying to get the slicer to behave the way I want.
This topic brings up the general issue of workflow ... how do people manage their projects, profiles, prints, and all the complexity that accompanies them?

Example of my Brief Profile Display format

Extruder: E-List [PrimExtr], Index Tool 0: Noz 0.40, ExtMult 1.00, ExtWid Man 0.40, Ooze Control: YES Retr, RetrDist 1.00, ExRestart 0.00, RVertLift 0.00, RSpeed 2400, Yes Coast, CoastDist 0.20, Yes Wipe, WipeDist 2.00

Layer: L-Extr [PrimExtr], LHt 0.10, TSolid 5, BSolid 4, Shells 2, Dir: InOut, No PISeq, No Vase, FHt: 150%, FWid 100%, FSpeed 50% (2400mm/m = 40mm/s), StartPoints: FastPrint

Additions: Yes Skirt, Sk-Extr PrimExtr, SkLayers 2, SkOffset 1.00, SkOutlines 2, No Raft, No Pillar, No Ooze

Infill: I-Extr PrimExtr, IntPat Rect, ExtPat Rect, Infill 30%, OutOvr 20%, InWid 100%, MinLen 5.00, Combine 1, No IncSolid, IntAng 45 / -45, No EvAngle, ExtAng 45 / -45

Support: No GenSupp

Temp: T-List [PrimExtr] T0, TType Extruder, No Layer, No Loop, Yes WaitStab, SetP 1:200°C,
T-List [HBed] T0, TType HBPlat, No Layer, No Loop, Yes WaitStab, SetP 1:60°C

Cooling: FanSpeed 1:0 / 2:100, No Blip, No Incr, No Bridge

G-Code: Yes 5D, No RelDist, Yes AllowZ, No Indep, No M101, Yes Sticky, No applyGOffsets, GOffsets X:0.00 / Y:0.00 / Z:0.00, Yes UpMDef, MType Cart, Build X:250 / Y:210 / Z:210, Orig X:0 / Y:0 / Z:0, Home X:Min / Y:Min / Z:Min, Flip No X, Yes Y, No Z, THeadOffsets [Tool 0] X:0 / Y:0, Yes UpdFirm, FType RepRap, Baud 115200

Scripts: S3D Std Starting & Ending

Speeds: SpDefault 4800 mm/min (= 80mm/sec), SpPerim 50%, SpSolidIn 80%, SpSupp 80%, SpXY 12000, SpZ 1000, No AdjBelow, AdjBelowSec 15, AdjDown 20%

Other: Area 50, ExInflat 0.00, BrExMult 100%, BrSpMult 100%, No FixedAngle, No BrPerim, HComp 0.00, F-List [Tool 0] FilDiam 1.75, FilPrice 46, FilDen 1.25, ChgRetDist 12, ChResDist -0.50, ChRetSp 600

Advanced: No Start, No Stop, ExThinType PerimOnly, InThinType GapFill, Overlap 25%. MinExLen 1.00, MinPWid 50%, MaxPWid 200%, EndExtDist 0.20, Yes Open, Yes ForceRet, No MinTRetr 3.00, Yes RetWipe, Yes WipeOuter, No AvoidCross, MaxDetour 3.0, NonManSeg Heal, No Merge.

MatterHackers Blue PRO Series PLA 1.75mm; 200°C / 60°C; Z=-0.725mm.
-- Clint Goss

max_kraemer
Posts: 1
Joined: Sat Aug 31, 2019 3:47 am

Re: Recovering Lost Processes

Sat Aug 31, 2019 3:50 am

Hey everyone,

I just had the same problem and found a solution:
Usually all process settings are added to any Gcode output as comments in the beginning.

Using the File->Import FFF profile
it is possible to select ANY of your previously made g-files and Simplify3D will extract the settings and create a profile using those.

Easy as that :)

Best regards,
Max

Return to “General Discussion and Tips”