pieri70
Posts: 2
Joined: Fri Apr 20, 2018 2:38 am

Logic between Profiles/Tools/Gcode scripts and temperatures

Fri Jul 06, 2018 3:22 pm

Hello
I'm struggling to understand how S3D behaves with prifiles, tools and temperatures and dual extruder machine.
If I'm not wrong Gcode scripts (start/end) are coupled with profiles and I have seen they also depend on auto-configure Extruders
For example I can set T0 at the beginning of my start gcode for auto configure for right extruder and I can put T1 on start for left extruder, then a purge sequence to prime my left/right extruder.

Right?

Then
Temperatures, There is no possibility to automatically heat only the desired extruder with a temperature taken from the temperature controller list.
I mean If I set 200 degree to both left and right extruder in controller list and I choose to auto-configure only left extruder both tools will heat.
I can set in controller list left to 200 and right to zero but then If I choose to auto configure only right extruder left ext will heat up and right will stay cold...
I have to set the heating up manually in my start gcode with something like this for auto-left

Code: Select all

T1; activate Tool 1
M104 S[extruder1_temperature] T1; set T1 Heat T1 to printing 
M109 S[extruder1_temperature] T1; wait T1 Heat T1 to printing
M104 S0 T0; Turn off T0
and this for auto right:

Code: Select all

T0; activate Tool 0
M104 S[extruder0_temperature] T0; set T0 Heat T0 to printing 
M109 S[extruder0_temperature] T0; wait T0 Heat T0 to printing
M104 S0 T1; Turn off T1
This works for me, but for example in case I'm auto configuring left extruder and I have a per-layer temperature set point for right extruder, then my right tool will heat at the layer set.

What is the best approach to deal with these problems?

Thanks for any help
Pietro

pieri70
Posts: 2
Joined: Fri Apr 20, 2018 2:38 am

Re: Logic between Profiles/Tools/Gcode scripts and temperatures

Sun Jul 08, 2018 1:33 pm

What I'd like to get is:
If I want to print with right HE (T0) configure the start and purge of the right HE (T0) with T0 HE heating and left HE staying cold.
If I want to print with Left HE (T1) configure the start and purge of the left HE (T1) with heating of the left HE and right HE staying cold.
Configure the start and purge of the right-hand HE (T0) and the left (T1) with HE heating of R/L in case I want to print in dual extrusion.

From what I have experienced so far I think I must set the start / end Gcode scripts
These basically depend on the auto-configure extruders setting and it seems logical to me, since I want a startup script if I want to print with R-HE, a different one if I want to print with L-HE and a different one if I want to do the both HE for dual printing ..

In the documentation and here I read that you can set the temperatures of the different "tools" in the start gcode and in this case then S3D does not do it automatically ..

Well, I'm almost there, this is my start gcode for R-HE (T0)
With the variable [extruderX_temperature] I read the print temperature from the print controller (T0 / T1) and use it in the start gcode

Code: Select all

;Gcode R-HE (T0)
M280 P0 F160 ; Reset BLTouch
M104 S[extruder0_temperature] T0
M104 S0 T1
M109 S[extruder0_temperature] T0
G92 E0; zero extruder
G28 ; Autohome
G29 ; Autolevel
G1 X-10 Y15 F5000; move to purging position
G1 E20 F150 ;purge the filament a bit before starting print
G92 E0; zero extruder
M530 S1; Start print
Here I set the heating of the T0 and I say to wait for temperature, I also set T1 to zero. The plate is arranged by S3D

Same for T1:

Code: Select all

;Gcode L-HE (T1)
M280 P0 F160 ; Reset BLTouch
M104 S[extruder1_temperature] T1
M104 S0 T0
M109 S[extruder1_temperature] T1
G92 E0; zero extruder
G28 ; Autohome
G29 ; Autolevel
G1 X0 Y15 F5000; ; move to purging position
G1 E20 F150 ;purge the filament a bit before starting print
G92 E0; zero extruder
M530 S1; Start print
Here I set the heating of the T1 and I say to wait, I also set T0 to zero. The plate is arranged by S3d

In order to use autoconfig correctly with [extruderX_temperature] variable for both DX and SIN, I have to set the print temperatures of the two controllers on the temperature tab in S3D.

The problem is that if I run the autoconfig for the R-HE (T0) S3d adds heat T1 at the temperature set for T1 taken from the temperature tab ...
Vice versa for T1, it also heat T0

Let's say that I want to auto configure R-HE with the start script above, the gcode generated by S3d is

Code: Select all

; G-Code generated by Simplify3D(R) Version 4.0.1
; Jul 7, 2018 at 7:02:08 PM
; Settings Summary
.....
;   printExtruders,Right Extruder Only
;   extruderName,Right Extruder T0,Left Extruder T1
;   extruderToolheadNumber,0,1
.......

G90
M82
M106 S255
G4 P500
M106 S0
M140 S80
M190 S80
M280 P0 F160 ; Reset BLTouch
M104 S230 T0
M104 S0 T1
M109 S230 T0
G92 E0; zero extruder
G28 ; Autohome
G29 ; Autolevel
G1 X-10 Y15 F5000; move to purging position
G1 E20 F150 ;purge the filament a bit before starting print
G92 E0; zero extruder
M530 S1; Start print
G92 E0
G1 E-5.0000 F3000
G1 Z0.300 F1002
; process Color1
; layer 1, Z = 0.200
M104 S230 T1
;G4 P1000
M105
T0
; tool H0.200 W0.460
; skirt
So at the beginning of layer 1 S3D set:

; layer 1, Z = 0.200
M104 S230 T1

And it heats T1 not abeying what I set in start gcode (M104 S0 T1)

Where am I wrong?

thanks
pietro

Return to “General Discussion and Tips”