winchymatt
Posts: 4
Joined: Tue Nov 13, 2018 1:33 pm

[FIXED] V4.1 Bridging Issues

Tue Nov 13, 2018 1:42 pm

Hi, I've just updated to V4.1 and spotted some differences in the generated GCODE files that may be an issue. This concerns bridging settings when using the settings: "Apply bridging settings to perimeters"

V4.0 would generate GCODE such as below which is to be expected:

Image

V4.1 generates some spurious bridging regions which are unexpected.

Image

SWCNT
Posts: 27
Joined: Mon Jul 16, 2018 9:51 am

Re: V4.1 Bridging Issues

Tue Nov 13, 2018 3:27 pm

Yeah I've noticed that too, it's applying bridge settings to outlines that aren't bridged and not applying bridge settings to some of the outlines that are bridges. I've gone back to 4.0.1

S3D-Alex
Posts: 339
Joined: Thu Aug 30, 2018 1:23 pm

Re: V4.1 Bridging Issues

Tue Nov 13, 2018 3:41 pm

Thank you for bringing this to our attention! Can you please provide a Factory File for this particular issue?

winchymatt
Posts: 4
Joined: Tue Nov 13, 2018 1:33 pm

Re: V4.1 Bridging Issues

Wed Nov 14, 2018 11:42 am

Hi,

Factory file attached.

Thanks.
Attachments
3701 technic_brick_1x4 (Bridging Issue S3D V4.1).factory
(262.25 KiB) Downloaded 82 times

S3D-Alex
Posts: 339
Joined: Thu Aug 30, 2018 1:23 pm

Re: V4.1 Bridging Issues

Wed Nov 14, 2018 1:18 pm

Thank you for providing the Factory File! I was able to reproduce the bridging error in my testing here and have documented my findings for the development team.

In order to work around this in the meantime I have found that turning off the "Coast at end" option and/or the option to "Apply Bridging Settings to Perimeters" will cause the file to slice correctly.

winchymatt
Posts: 4
Joined: Tue Nov 13, 2018 1:33 pm

Re: V4.1 Bridging Issues

Thu Nov 15, 2018 11:29 am

Hi,

Ahh ok. I'll try removing the coast at end option. Thanks.

winchymatt
Posts: 4
Joined: Tue Nov 13, 2018 1:33 pm

Re: V4.1 Bridging Issues

Fri Nov 16, 2018 4:17 am

Hi, Coast at end option does indeed remove the spurious bridging lines, however, the bridging still isn't as good as V4.0 IMO.

S3D-Jake
Posts: 711
Joined: Wed Jun 20, 2018 12:45 pm

Re: V4.1 Bridging Issues

Wed Dec 12, 2018 2:30 pm

I’m happy to state that this issue should be resolved now in the latest 4.1.1 release. Our team successfully tested your factory files from threads mentioning this issue. The combination of coasting and apply bridging settings to perimeters will no longer result in the bridging settings getting applied to non-bridging regions. This was just one of many improvements to the software. All of which are detailed on our Release Notes page.
Screen Shot 2018-12-12 at 2.28.39 PM.png
Technic_brick sliced in 4.1.1
Thank you for your help reporting this issue!
"A bird does not sing because it has an answer. It sings because it has a song."

Return to “General Discussion and Tips”