PhilipdeJ
Posts: 2
Joined: Tue Aug 27, 2019 7:07 am

wrong size of object from blender

Tue Aug 27, 2019 7:38 am

Hi All,

My first hours with the program. I try to import an STL file from Blender 2.8, it's size is in cm, but I get a very small object in Simplify3d in millimeters.
Can't find a place to correct or change the size of the object by number. It's, as far I can see, only possible by hand, but than I can't see the precise sizes. What do I miss? How do I do that? Changing cm in mm in Blender does not help either.
I hope to get some help, thanks in advance,

Philip

wirlybird
Posts: 1215
Joined: Sun Jul 17, 2016 1:32 pm

Re: wrong size of object from blender

Tue Aug 27, 2019 9:01 am

Double click on the model in S3D and a panel will open on the right. There you can scale to go from CM to MM.

User avatar
dkightley
Posts: 2040
Joined: Tue Mar 10, 2015 4:09 pm

Re: wrong size of object from blender

Tue Aug 27, 2019 9:21 am

Wirlybird's answer is okay for a one-off occasion.....but if you have this issue every time, then a more permanent solution is possible.

Firstly, do bear in mind that stl files do NOT hold any dimension information..ie mm or cm or inches, etc. The values in the stl file are simply UNITS...where one UNIT can be anything!

There are two ways to resolve....change the default units in Blender. I don't use Blender so I can't advise how its done....but you should be able to define somewhere what one unit equates to for exporting shape data....either 1mm , 1 cm, 1 inch, etc. Alternatively, you can either do as Wirlybird has suggested, or use the import scaling ...Tools> Options> Models tab to enter a default import scaling action that will apply to every load.
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

PhilipdeJ
Posts: 2
Joined: Tue Aug 27, 2019 7:07 am

Re: wrong size of object from blender

Tue Aug 27, 2019 10:40 am

Thank you both for the quick reply.

Return to “General Discussion and Tips”