albrechtmyers
Posts: 1
Joined: Thu Jan 30, 2020 10:31 pm

need heating advice

Fri Jan 31, 2020 2:32 am

Hello,
can I somehow configure Simplify so that the hotend and the table are turned on for heating at the same time, and then the printer expected the table to warm up?
Everything is correct in the code itself, but the table is earlier (waiting for its heating). but it is necessary on the contrary - to put M104 before M190.

Code: Select all

M140 S110
M190 S110
M104 S240 T3
https://4kpornindex.com/

Ret
Posts: 72
Joined: Wed Feb 07, 2018 4:26 pm

Re: need heating advice

Fri Jan 31, 2020 11:32 am

You can heat them simultaneously, but I don’t recommend it. The bed takes significantly longer to heat than a hotend. Your hotend will be sitting there oozing and burning filament while the bed is heating.

Here’s how to do it(you may need to change tool names):

Code: Select all

M104 S[extruder0_temperature] T0    ;sets hotend temp WITHOUT wait
M140 S[bed2_temperature]            ;sets bed temp WITHOUT wait
M109 S[extruder0_temperature] T0    ;sets hotend temp WITH wait
M190 S[bed2_temperature]            ;sets bed temp WITH wait
I suggest doing it like this though(temps to be adjusted):
Heat your bed to 55, then turn on your extruder heater and when your bed hits 60, your hotend should be at its temp. This way you’ll burn less filament and ooze less. All around a better approach.

Code: Select all

M190 S55                            ;sets bed temp WITH wait
M140 S[bed2_temperature]            ;sets bed temp WITHOUT wait
M109 S[extruder0_temperature] T0    ;sets hotend temp WITH wait
M190 S[bed2_temperature]            ;sets bed temp WITH wait
I haven't tested either of these but it SHOULD work. Be next to you printer in case things don't heat correctly. Verify the Gcode matches your firmware as well.

Return to “General Discussion and Tips”