jmagma
Posts: 1
Joined: Sat May 22, 2021 4:40 pm

Ender 5 Plus V 1.70.2 Pause At Layer Script

Sat May 22, 2021 5:30 pm

Hi Everyone,
I have an Creality Ender 5 Plus V1.70.2 printer (excellent machine), and I'm having trouble determining the best way to execute a 'pause at layer' gcode command. I'm trying to accurately insert a part to be embedded into the print, so I've determined a specific layer/height that will work. I've done this by watching and manually pausing the print, but the print takes 7 hours (that's a long time to wait!). I've tried multiple methods. Here's the script I've tried, but each time I use it or try an edited version of it, it seems to have no effect. I'm placing the below script into the 'Additional Terminal Commands for Post Processing' section of the scripts tab of the 'Edit Process Settings' menu. I found this one on youtube, but haven't found a script that people are specifically using with my printer:

;Filament change code below. Specify layer to swap filament. Print will pause and you can change filament, click LCD button to resume print.
;{REPLACE "; layer" "M117 Layer"}; show layer number and Z height on LCD
;{REPLACE " Z = " " Z="}; make room on LCD for text
;{REPLACE "\nM117 Layer 51, Z=" "\nG1 X10 Y5\nM300 S1000 P1000\nM0\nM117 Layer 51, Z="}; pause at layer, move head, play sound

Also tried this:

;{REPLACE "\nM117 Layer 5, Z=" "\nG1 X10 Y5\nM300 S1000 P1000\nM0\nM117 Layer 5, Z="}; pause at layer, move head, play sound

This printer uses Marlin/RepRap Gcode format. Does anyone know what I'm doing wrong or missing?

I've also tried printing the model by using the 'Variable Settings Wizard' to create a split process, and edit the start and end Gcode scripts of each process. This worked great except my printer has a BKTouch installed, and each time I initiate a print the printer automatically tries to touch off the print bed to determine the Z offset. I have not found a way to disable this feature in the printer settings. Because of this I cannot have a partial print still on the print bed without crashing the extruder head when I initiate the second part of the 2 step split process. I'm certain that this feature is built into the firmware of the printer itself because when I print live from simplify 3d I can see that the printer is 'busy' during this process in the communication display of the 'Machine Control Panel'. Does anyone know how to disable that feature? Turning off auto leveling in the printer menu doesn't work either. I'm not skilled enough to execute a firmware edit. I feel like I would be asking for trouble by attempting that!

I think the only way to accomplish the pause at layer function with my printer is to use a script.

Any help would be appreciated. Thanks!!!

Return to “General Discussion and Tips”