Page 1 of 1

Start gcode for dual extruding on a Makerbot Replicator 2X

Posted: Tue Nov 19, 2013 4:43 pm
by Nextgen3D
Hi all,

I’m hoping someone can help.

I need to alter the start gcode in Simplify 3D for when I dual extruding on a Makerbot Replicator 2X.

At the moment only the right extruder is priming before the slow wipe at the beginning of the print. This is fine if you are just using the right extruder but not ideal when you are using both extruders.
Could someone tell me the additional code I need to add to get the left extruder (T1) to prime before the sweep.
I think it need to go somewhere in the highlighted code below.

Thank

; **** Replicator 2X start.gcode ****
M103 ; extruder off
M73 P0 ; enable build progress
M70 P2 (Simplify3D Creator)
G162 X Y F3000 ; home XY maximum
G161 Z F1200 ; home Z minimum
G92 Z-5 ; set Z to -5
G1 Z0.0 ; move Z to 0
G161 Z F100 ; home Z slowly
M132 X Y Z A B ; load current position from EPROM
G10 P1 X-125 Y-75 ; set local offset for Creator
G10 P2 X-125 Y-75 ; set local offset for Creator
G54 ; enable G10 offset
G1 X-5 Y0 Z30 F9000 ; move to wait position off table
G130 X20 Y20 Z20 A20 B20 ; lower stepper Vrefs while heating
M70 P1 (priming nozzle...)
M6 T0 ; wait for extruder to warm up
G130 X127 Y127 Z40 A127 B127 ; default stepper Vrefs
G1 Z0.4 ; position nozzle
M108 R5.0 ; set extruder speed
M101 ; start extruder
G4 P3500 ; purge nozzle

G1 X0 Y5 Z0.15 F1200 ; slow wipe
M103 ; stop extruder
G1 X5 Y10 Z0.5 F1200 ; lift
M73 P1 ;@body (notify GPX body has started)
; **** end of start.gcode ****