onus
Posts: 2
Joined: Thu Nov 30, 2017 10:31 am

On Resuming a print.

Okay, I don't know if anyone else has encountered this. (I should think you would have...)

So here is the scenario:

Your printing along fine, when out of the blue your print head snags on a warped part of your print!
Luckily you were right there! Caught it immediately (no time to waste, save this 9 hour print that's 4 hours in!)
So you pause the print, drop the bed for clearance, home x, home y. (maybe push down on the warped bit.)
[here's where it gets funky]
You extrude a little plastic, to prevent it from burning and keep things moving along - nobody likes dealing with a clog.
But when you resume you print... not only does it put the print head back where it needs to be (now just right no longer off in the x or y - cuz we homed those bad boys) and bring the print bed back up to the right height. [All good so far.]
Then it does something unexpected.
It extracts filament! exactly how much you've extruded in the few minutes its has taken to get your print/printer ready to print again.

How do I disable this?? It's terribly difficult to push the filament back in while the head is moving -risking knocking x or y out of position again...

Did I miss something?
Do you understand my issue?

I tried asking Simplify3d Support. and they gave me this:

"It looks like you need to create a new Macro that when pressed executes a set of commands like
1. moving the tool away
2. pause
3. prime a little
4. resume back to the print"

I'm not sure that that is what I need.
Although I'm not sure what they mean by new macro. -Would I be changing out the current set of commands that tell it to put everything back to exactly how it was before the print was paused: including extracting filament, and replacing it with more succinct and logical set of commands? OR
am I adding to the current set and compounding my issue?

OR am I completely off track and in need of a good redirecting?

Thanks for any and all input!
-onus
brian442
Posts: 1243
Joined: Mon Nov 28, 2016 5:35 am

Re: On Resuming a print.

It sounds like your gcode file might be using absolute E-values. That means that if you do a lot of jogging in the middle of the print, it will try to go back to the same absolute position when it starts printing again.

Can you try going to the G-Code tab of your process settings and enabling the "relative extrusion distances" option? That will make the E-values relative so that jogging won't affect them.
onus
Posts: 2
Joined: Thu Nov 30, 2017 10:31 am

Re: On Resuming a print.

I appreciate it going back to where left off. wonderfully. its good.
I just want it to stop retracting any filament I may have extruded.
I have to affect all settings not just the single one I would like to change??

That seems odd.
brian442
Posts: 1243
Joined: Mon Nov 28, 2016 5:35 am

Re: On Resuming a print.

Just change the one option I mentioned above and it should work.

Return to “General Discussion and Tips”