t77chevy
Posts: 1
Joined: Mon Jan 01, 2018 11:20 am

Bed mapping " G29" causes intermittent heaters

Mon Jan 01, 2018 11:30 am

Installed a th3d probe with Marlin 1.1.16 to my cr10s , I used default start script and just added the G29 code after the G28 in the starting script .

The problem I have is the temps flash for both hotend and bed and seems to turn off the heaters while flashing , seeing its already waited on hotend and bed to reach temps after bed mapping " G29" it starts to print even though hotend is below print temp " for example I had it set to 200c for pla and hotend was at 165c after mapping and went to start printing "

To get around this I just added a m109 and told it 200c for this print in start script so it would again wait till temp

My question is is there a code I can use that will pull the set sliced temps for hotend and bed so I don't need to mod this start script with every temp difference I need , for example pla for hotend I use 200c on average and say petg I'm using 230c , I don't want to forget to change the start script to match required temps for a print job

SimpleScott
Posts: 42
Joined: Tue Jan 12, 2016 7:23 pm

Re: Bed mapping " G29" causes intermittent heaters

Wed Jan 03, 2018 1:29 pm

You can place these variables in your start/end script, and they will be replaced with temperatures from the profile:

[bed0_temperature]
[extruder0_temperature]

For example:
M109 S[extruder0_temperature] ; set extruder temp and wait
M190 S[bed0_temperature] ; wait for bed to finish heating

Return to “General Discussion and Tips”