JonnieCache
Posts: 2
Joined: Sun May 27, 2018 9:45 am

[SOLVED]S3D inserts additional, unwanted heatbed code

Mon Jul 16, 2018 7:25 am

Hi. I have noticed that the GCODE created by S3D doesn't seem to respect my startup code. My startup script starts with:

M115 U3.2.1 ; tell printer latest fw version

However the created GCODE starts with this:

G90
M83
M106 S0
M140 S60
M190 S60
M115 U3.2.1 ; tell printer latest fw version

The first 3 lines aren't an issue, but I don't want it to put M140 and M190 in there yet. It causes it to heat up the bed before also asking the extruder to heat up. Is this a bug in S3D?

Thanks!

Jonnie

User avatar
DarthRevan
Posts: 451
Joined: Wed Feb 18, 2015 8:29 am

Re: S3D inserts additional, unwanted heatbed code

Mon Jul 16, 2018 8:59 am

If you want to a specific sequence for heating your extruder(s) and bed, you can include that sequence in your starting g-code script from the scripts tab. Make sure to use the temperature variables for setting the bed and extruder temperature.... Using the variables causes the initial heating of your extruder and bed to be handled by the starting script instead of the automated g-code generation which places them in the order you're seeing currently.


Ex: [extruder0_temperature], [bed0_temperature], etc...
More on those variable here: viewtopic.php?f=8&t=1959
More on custom g-codes: https://www.simplify3d.com/support/arti ... -tutorial/

JonnieCache
Posts: 2
Joined: Sun May 27, 2018 9:45 am

Re: S3D inserts additional, unwanted heatbed code

Mon Jul 16, 2018 4:49 pm

Ah! That worked! I didn't realize that you had to use the variable in order to stop S3D from putting it in itself.

Return to “Troubleshooting and Bug Reports”