Frezzno88
Posts: 3
Joined: Tue Jul 31, 2018 12:09 pm

Z dimension issues

Tue Jul 31, 2018 12:24 pm

Hello

I searched the forum and saw that other had the simililar problem but still not really.

viewtopic.php?f=9&t=6402&p=27803&hilit= ... ion#p27803
viewtopic.php?f=9&t=5806&p=25140&hilit= ... ion#p25140

When I print a 20*20*20 cube. X and Y har close to 20 but the height is 19,8 something.

That is almost the same as in the other threads.
But i print with 0,2 layer height and in the print preview the Z stop in 20.040.
But in octoprint GCode viewer it says the model is 19,84 mm high which is really close to most of my cubes.

Any on else had this?
What is wrong?
Is there any fix to the GCode from simplify3D?

User avatar
DarthRevan
Posts: 469
Joined: Wed Feb 18, 2015 8:29 am

Re: Z dimension issues

Thu Aug 16, 2018 1:03 pm

Can you post your G-Code? It could have something to do with first layer settings and the way 0.2mm layer height as a result wouldn't divide into 20mm evenly after the first layer height is taken into account.

Frezzno88
Posts: 3
Joined: Tue Jul 31, 2018 12:09 pm

Re: Z dimension issues

Thu Aug 16, 2018 2:59 pm

Here it is.
Attachments
20mm_cube_soft_edges.gcode
(183.98 KiB) Downloaded 52 times

User avatar
DarthRevan
Posts: 469
Joined: Wed Feb 18, 2015 8:29 am

Re: Z dimension issues

Fri Aug 17, 2018 9:45 am

Frezzno88 wrote: Hello

...But i print with 0,2 layer height and in the print preview the Z stop in 20.040.
But in octoprint GCode viewer it says the model is 19,84 mm high which is really close to most of my cubes.

Any on else had this?
What is wrong?
Is there any fix to the GCode from simplify3D?
Your first layer height is set to 120% if you set it to 100% your ending height will be exactly 20mm.

As for Octopi reporting a different height, I don't know why that is, as I've confirmed the last layer is printed at 20.040mm.

Frezzno88
Posts: 3
Joined: Tue Jul 31, 2018 12:09 pm

Re: Z dimension issues

Fri Aug 17, 2018 11:41 am

That g.code says
20,04 in simplify3d
19,84mm in octoprint

the print comes out at 19,86

when i have 100% the programs says:
Simplify3d 20,00
Octoprint 19,8

The print come out at 19,94 wich is closer to what it should be.

Weird thing with the ocotprint and the wrong height in 120% but now it comes of right. thank you :)

User avatar
DarthRevan
Posts: 469
Joined: Wed Feb 18, 2015 8:29 am

Re: Z dimension issues

Tue Aug 21, 2018 3:50 pm

I don't know what we did to fix it, but glad it helped! :)

Return to “Troubleshooting and Bug Reports”