Le_Don_Macaron
Posts: 7
Joined: Thu Aug 02, 2018 9:34 am

Bad perimeters with High-poly models

Thu Aug 02, 2018 11:49 am

Hi,

I'm getting strange wobbles in the toolpaths generated for models with lots of polygons. (I need my models to be high-poly because I am using displacement maps to "engrave" details into them in Blender).
The models themselves appear perfectly smooth, but as soon as I "prepare to print", the bumps appear in the sliced result.

Hi Poly model:
Hi Poly Paths.png
Med Poly model:
Med Poly Paths.png
Low Poly model:
Low Poly Paths.png
As you can see, the problem gets worse with a higher number of polygons. Any ideas what's happening here?

The problems only seems to exist on parts on the model which are *almost* straight lines, so I wonder if it's perhaps something to do with Simplify trying to interpolate between loads of points which are not fitting within some kind of tolerance?

Le_Don_Macaron
Posts: 7
Joined: Thu Aug 02, 2018 9:34 am

Re: Bad perimeters with High-poly models

Wed Aug 08, 2018 8:25 am

Anyone got any ideas?

User avatar
DarthRevan
Posts: 464
Joined: Wed Feb 18, 2015 8:29 am

Re: Bad perimeters with High-poly models

Wed Aug 08, 2018 8:52 am

Can you upload your factory files or link them if they're too large to upload here?

Le_Don_Macaron
Posts: 7
Joined: Thu Aug 02, 2018 9:34 am

Re: Bad perimeters with High-poly models

Wed Aug 08, 2018 11:06 am

Yes - will do


Le_Don_Macaron
Posts: 7
Joined: Thu Aug 02, 2018 9:34 am

Re: Bad perimeters with High-poly models

Thu Aug 09, 2018 8:43 am

That's the hi poly one with the issues. Do you need to see the lower poly ones too?

User avatar
DarthRevan
Posts: 464
Joined: Wed Feb 18, 2015 8:29 am

Re: Bad perimeters with High-poly models

Thu Aug 09, 2018 10:30 am

I'm not entirely sure what the issue is, but the model does get detected as having self intersecting surfaces. I've seen slicing irregularities stem from model issues before. They're in multiple places but on outer face they seem to be right along where the issues are showing up in the preview.
Self Intersecting Surfaces.png

Le_Don_Macaron
Posts: 7
Joined: Thu Aug 02, 2018 9:34 am

Re: Bad perimeters with High-poly models

Tue Jul 30, 2019 10:25 am

In case anyone else has this problem - I eventually solved it by using the Decimate modifier in Blender to reduce the number of faces by approximately half, then re-exporting the STL. No visible change to the model, but Simplify was then able to slice it cleanly.

Return to “Troubleshooting and Bug Reports”