beast75
Posts: 2
Joined: Tue May 27, 2014 2:25 pm

end script

Tue May 27, 2014 2:37 pm

Hi, after the print is finished, the extruder stop at the last point, dont turn off the hot end and don´t´turn off the motors. I also can´t sent a command after printing, only a emergency stop will be accepted. After the e.s. the commands will be accept.

I have a "HAGE 3Dp A2" Printer with 2 extruders and heated bed.

Maybe i need a different end script. Can anyone help me?

Thanks a lot

beast75
Posts: 2
Joined: Tue May 27, 2014 2:25 pm

Re: end script

Wed May 28, 2014 5:08 am

solution found:
M104 S0 T1 ; turn off extruder
M104 S0 T0 ; turn off extruder
M140 S0 ; turn off bed
G28 X0 ; home X axis
M84 ; disable motors

i have used M109 S0
that was the error

industrialdesign
Posts: 1
Joined: Wed Aug 19, 2015 8:56 am

Re: end script

Wed Aug 19, 2015 9:05 am

Hi beast75,
we have these lines in our endscript to remove the extruder:

Code: Select all

; Default end code
G91 ; Relative positioning
G1 Z10 ; move 10 up from last position
G90 ; Absolute positioning
G1 X350 ; move to the rear end to remove parts
M107 ; Turn off fan
G91 ; Relative positioning
M104 T0 S0
M104 T1 S0
G90 ; Absolute positioning
G92 E0 ; Reset extruder position
M140 S0 ; Disable heated bed
M84 ; Turn steppers off

jlovett
Posts: 4
Joined: Mon Feb 04, 2019 4:03 pm

Re: end script

Tue Feb 05, 2019 1:09 pm

That part in your code about Z move 10 up if you're printing something at max build height would that cause the print to be jammed into the hot end? We're seeing this happen with some of our larger prints and I'm troubleshooting it. We have 4 Dremel 3D45s.

Return to “Troubleshooting and Bug Reports”