Matt-
Posts: 4
Joined: Sat Oct 14, 2017 2:49 am

Print preview does not match shape

Thu Oct 11, 2018 11:30 pm

All,

I have a really odd problem that I can't figure out.

I have designed a simple box for a project I'm working on that includes a lip so that I can attach a lid. I can import the shape into S3D and it shows correctly in the main window:
Shape.jpg
However, when I click the 'Prepare to print' button, the print preview excludes the lip and the resultant print matches the print preview:
Print Preview.png
I can only assume there is something wrong with my print settings but I am not sure where to look for it. I've tried changing the top solid layers and the perimeter shells without success.

Can anyone suggest where I'm going wrong?

TIA.
Attachments
ESP32 Case.stl
(44.32 KiB) Downloaded 61 times

User avatar
dkightley
Posts: 2302
Joined: Tue Mar 10, 2015 4:09 pm

Re: Print preview does not match shape

Fri Oct 12, 2018 9:54 am

The "missing" lip is thinner than the extrusion width that you have set up in your settings....and S3D will refuse to print it as a way of advising you that the shape cannot be printed. Obvious, isn't it??

What you need to do is to change the Thin Wall Behaviour in the Advanced tab. Change the External Thin Wall Type to "Allow Single Extrusion Type" and then set the Single Extrusion Printing Width to ...at a guess...50%.


You should get the lip showing in the preview....and printing.
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

Matt-
Posts: 4
Joined: Sat Oct 14, 2017 2:49 am

Re: Print preview does not match shape

Fri Oct 12, 2018 6:41 pm

That fixed it.

Thank you so much, Doug!

Return to “Troubleshooting and Bug Reports”