Eddiie
Posts: 6
Joined: Wed Sep 27, 2017 11:42 pm

Printer crashes at the start of the second layer

Sat Oct 20, 2018 6:41 pm

Hi,
I have made a Toyrep printer a couple years back. Over time I've upgraded it to use 'normal' steppers for the X and Y axis. It runs Marlin firmware and has for years.
Before purchasing Simplify3D, my slicer of choice was Cura. It took me a year to finally migrate settings from Cura to Simplify for this little printer.

Finally I did. Shortly thereafter, I started getting temp alerts and crashes during print jobs. MINTEMP Heater_ID0 Wow, ok. I replace the hotend, thermistor, wiring, main board, controller, power supplies, absolutely everything I could think of. Then I thought let me try going back to Cura as a test.. Sure enough, there is no crash on temp alerts any more. Still not willing to believe it, I looked to Marlin, tried different versions of the firmware, it didnt change anything.

This is the course of around 4 months.

Finally, I have a model/gcode that consistently makes the printer report temp alert at the SAME place every time. The temps are FINE by the way.

Can you help me find out what is happening and more importantly how to NOT make it happen.. ever (without turning it off in the firmware of course).

Note, I have several other printers, mostly running Marlin, too, different versions, pretty sure its not the firmware..

So, here is some gcode from my file, just after it completes the first layer (layer 0).... For the record, the first layer prints, Z motors move the carriage up, the fan part-cooling fan turns on, extruder moves, printer moves as it should (on the X plane) THEN stops, reports heat error.

Any ideas? Again, Cura works fine. This is a repeatable example...

Here is the code, I have not honed in on the exact line yet -

...this is the end of first layer...
G1 X42.095 Y103.864 E227.0839
G1 X48.014 Y109.783 E227.3846
G92 E0
G1 E-1.2500 F207
; layer 2, Z = 0.380
M106 S255
; inner perimeter
G1 X48.677 Y109.377 F5000
G1 Z0.380 F1000
G1 E0.0000 F207
G92 E0
G1 X47.848 Y108.832 E0.0356 F3750
G1 X47.044 Y108.243 E0.0714
G1 X46.265 Y107.610 E0.1075
G1 X45.751 Y107.156 E0.1321
G1 X45.197 Y106.626 E0.1597
G1 X44.427 Y105.822 E0.1996
G1 X43.882 Y105.191 E0.2296
G1 X43.226 Y104.357 E0.2677
G1 X42.724 Y103.651 E0.2988
G1 X42.202 Y102.841 E0.3334
G1 X41.720 Y102.009 E0.3680
G1 X41.278 Y101.154 E0.4026

Return to “Troubleshooting and Bug Reports”