GLMiller
Posts: 4
Joined: Wed Apr 18, 2018 4:12 pm

[FIXED] Loading then running g-code file causes 4.1.0 shut-down

Fri Nov 16, 2018 1:18 pm

I used drag-and-drop to load a g-code file on v4.1.0, then told it to print, which caused a program shut-down. The same file dragged and dropped on v4.0 works perfectly. The g-code file was originally generated by v4.1.0. Anyone else have this problem?

User avatar
SteveIsHeer
Posts: 48
Joined: Thu Sep 24, 2015 5:45 pm

Re: Loading then running g-code file causes 4.1.0 shut-down

Fri Nov 16, 2018 6:27 pm

Yes, I am experiencing this behavior as well in 4.1 but not previous releases. Also if you click run "Run Selected G-Code" to print something in your library, it prints but the preview screen does not show the model, only the little box bottom right corner that says "Printing....." Trying to print a G-Code file by selecting File-Preview G-Code File, it will load the file but as soon as I hit print, it crashes S3D. All files in my library are from previous versions of S3D. None of these issues happened in any of the previous version since version 3.0 when I first purchased the software.
It show's to go you how feelish you fool when your tang is all tungled up and you bart stalking tackwards!

GLMiller
Posts: 4
Joined: Wed Apr 18, 2018 4:12 pm

Re: Loading then running g-code file causes 4.1.0 shut-down

Fri Nov 16, 2018 10:04 pm

Yep, sounds like you have the same issue with the g-code. As indicated, this problem seems to exist only with v4.1.0. I bought v3.0 fairly soon after it first came out. Another mod I'd like to see is the heater controls made so we can arrange the order in which they turn on. So far, I haven't found a way around how they have hard-coded the process. I'd like to see the bed and hot-end be turned on first, then the "wait" versions turned on after those complete. This ability to reconfigure the heating process would be nice. My Prusa MK3 turns on both heaters, then activates the bed temp "wait" mode, then the extruder "wait" mode once the bed has reached temp. I have found that this speeds up the heating process and the printing gets underway somewhat sooner. This also defeats the "bug" I have run across where once the bed has heated and moved on to heat the extruder, but the extruder heater doesn't turn on. Real annoying when it does that.

Here's an example of what I'd like to be able to do....
M140 S60 ; turn on bed -- no wait
M104 S210 ; turn on ext -- no wait
M190 S60 ; pause until bed has heated, then continue
M109 S210 ; pause until ext has heated, then begin printing

S3D-Jake
Posts: 697
Joined: Wed Jun 20, 2018 12:45 pm

Re: Loading then running g-code file causes 4.1.0 shut-down

Wed Dec 12, 2018 2:52 pm

I’m happy to state that this issue with running imported G-Code files should be resolved now in the latest 4.1.1 release. Our team successfully tested multiple factory files from threads mentioning this issue in various scenarios. The imported G-Code will now begin printing rather than the software crashing. This was just one of many improvements to the software. All of which are detailed on our Release Notes page.

Thank you for your help reporting this issue!
"A bird does not sing because it has an answer. It sings because it has a song."

Return to “Troubleshooting and Bug Reports”