Posts: 1
Joined: Sun Nov 18, 2018 4:39 am

Bug in 4.1 with first layer of print

Sun Nov 18, 2018 4:50 am

I spent the last day going crazy trying to figure out why my prints were having trouble sticking (or even really seeming to extrude) during the first layer. I thought maybe I had hit a defective portion of filament and tried different ones. I thought maybe my BuildTak surface was "contaminated" somehow by oils from my skin from me touching it, but replacing it with a new BuildTak did nothing.

When prints first start the printer barely seemed to be extruding, essentially just putting out tiny spurts here and there. After trying the stuff above, I thought maybe my printer itself was having issues and tried to manually push through the filament, and saw that actually worked, so I ended up printing the full first layer with my manual help on the filament. But then I saw that the second layer printed perfectly fine without me helping. That gave me a hunch that it was maybe related to the new 4.1 software. Long story short, reverting back to 4.0.1 fixed the first layer issue.

So this post is mostly a heads up to anyone seeing the same thing, and also hopefully to the developers, to whom I'm happy to provide my gcode files if they would be useful in tracking down the bug. Also, for what it's worth, I have a Flashforge Dreamer.

Posts: 21
Joined: Mon Mar 20, 2017 11:55 am

Re: Bug in 4.1 with first layer of print

Thu Nov 22, 2018 3:57 pm

I had no issues moving to 4.1 at all.

Posts: 2
Joined: Fri Nov 23, 2018 12:57 pm

Re: Bug in 4.1 with first layer of print

Fri Nov 23, 2018 1:02 pm


I have the bug also. I was printing a 780mm plaque and on the first layer at about 40% it started printing ROGUE lines across the entire bed, then at some point it still was making moves to print but the extruder wasnt spinning. Ultimately it ended up jamming. I tried 4 times before i searched "simplify3d 4.1 bug" and here we are. I knew something wasnt quite right and the only thing ive done is updated from 4.0.1 to 4.1. Im currently trying 4.0.1 now and will report back if it doesent work, but im sure it will as it was working just before the update.

Posts: 2
Joined: Fri Nov 23, 2018 12:57 pm

Re: Bug in 4.1 with first layer of print

Fri Nov 23, 2018 3:06 pm

rollback 4.0.1 fixed my issue

Posts: 7
Joined: Tue Nov 27, 2018 2:38 pm

Re: Bug in 4.1 with first layer of print

Tue Nov 27, 2018 3:13 pm

I'm also having issues with first layer. With 4.1 I hear filament grinding when it "retracts" between perimeter and infill on the first layer, and see it squirt out extra instead of retracting. It randomly does the same on subsequent layers. It's also pretty notably underfilling the first layer regardless of 1st layer settings (unless it's just thin features), unless I bump up the perimeter overlap to the point where I get bad top layers.
I generated gcode for the exact same part with the exact same settings in 4.0.1 with zero issues, quiet as the machine could possibly be. Good faces all around, no blobs or real cleanup needed. The grinding seems to be related to thin feature infill. Part shown is an stl export from solidworks, there aren't any bad faces or weird geometry to contend with. Just a cylinder that tapers to a flat face with a fillet on the outside, chamfer on the inside
4.0.1 on the right

Posts: 237
Joined: Wed Jun 20, 2018 11:45 am

Re: Bug in 4.1 with first layer of print

Wed Dec 05, 2018 4:12 pm

The first layer extrusion behavior was changed between versions 4.0.1 and 4.1. If everyone can attach factory files our team can review and suggest solutions for updating your settings in 4.1 to perform as they would have in 4.0.1.

"A bird does not sing because it has an answer. It sings because it has a song."

Return to “Troubleshooting and Bug Reports”