Posts: 2
Joined: Sat Dec 15, 2018 4:57 pm

Issue with color change

Sat Dec 15, 2018 5:07 pm

I'm using a Anet A8 with Marlin 1.1.8 and at first I tried the Prusa color print and defined the height for the changes.. I later noticed in the day it never stopped.. so I stopped to do a manual change by pausing it.. something crazy happened so all it did was retract the filament and try to start again but it never worked..

Long story short I need to know how to use the M600 commands.. because this is a 19 hour print I can't stay and watch it like a baby.. now what my script setting looks like now is this (I havn't added anything)

{REPLACE "; layer 209," "M600\n; layer 209,"}
{REPLACE "; layer" "M117 Layer"}
{REPLACE " Z = " " Z="}
{REPLACE "\nM117 Layer 53
Z=" "\nG1 X10 Y5\nM300 S1000 P1000\nM0\nM117 Layer 53

Is all this even right should it even be in this area? I just want to do a very simple color change by layer height assuming the layers in the preview match what the printer prints out it should be really easy?

Posts: 927
Joined: Wed Jun 20, 2018 12:45 pm

Re: Issue with color change

Wed Jan 09, 2019 5:18 pm

Mixing M0 and M600 shouldn't be necessary. One or the other should be used in both areas. Depending on your firmware the M600 may or may not be supported. Also, there may be a time out function for any sort of pause command. I wouldn't imagine any pause will simply just resume printing without a user telling it to do so. I'd think that unless both pauses were ignored by the printer, you likely saw the M0 get skipped that should have been at layer 53. So try replacing that with M600 and see how that works for you.
"A bird does not sing because it has an answer. It sings because it has a song."

Return to “Troubleshooting and Bug Reports”