EvoOlli
Posts: 5
Joined: Mon Feb 05, 2018 1:08 pm

Slow Start of S3D

Sat Jan 12, 2019 5:34 am

I've had the problem that S3D started very slow (V4.01 and V4.11), sometimes it takes 2 Minutes until the program opens. Today I detected, that the cause of this is the G-Code Library in the Machine Control Panel. There were a lot of items in the list (I'm using S3D since nearly one year). It seems that the program checks all the files for existence and as all my files are on a WIFI-SDCard, it takes some time, especially if the printer is off.

Now what I'm missing is a "Remove ALL Items from Library" Button in the Machine Control Panel, because it's a lot of work to Remove them from the Library Item by Item.

I did a shortcut and cleared the Registry Key 'Communicator/gCodeLibrary' :-)

wirlybird
Posts: 1046
Joined: Sun Jul 17, 2016 12:32 pm

Re: Slow Start of S3D

Mon Jan 14, 2019 8:01 am

The gcode library issue has become a real problem. It can hang up S3D while opening for quite a long time.
We really need to be able to disable the save to library feature or the checks while opening.

I am now finding that even a few (5-6) gcode file in the library can really stall S3D from opening.

EvoOlli
Posts: 5
Joined: Mon Feb 05, 2018 1:08 pm

Re: Slow Start of S3D

Wed Jan 16, 2019 4:29 am

Especially as it is not useful when you write the files to an SDCard/WifiCard and delete them after printing.

A good idea would to build up a real library /archive where S3D copies all generated gcode files in their different generations, so you can look what you've done some weeks before or reuse the gcode. OK, this backup would grow big, but in these days of Terabytes it shouldn't be a problem.

Return to “Feature Requests”