acope007
Posts: 1
Joined: Fri Jan 25, 2019 10:51 pm

Settings will not update - PrintrBot Simple Metal

Fri Jan 25, 2019 10:57 pm

I have a rintrbot simple metal and installed the x axis upgrade with the heated bed making the build surface larger than previous. When I go in and try to update the size in the process settings it allows me to input it, but when I run the process it will not print using the entire surface. when I jog the controls, I will not let me move past th e150mm point when the entire bed is 250mm in length. I also have not been able to set the correct z height using the factory controls. Is anyone else having these issues or know what I am doing wrong?

User avatar
DarthRevan
Posts: 461
Joined: Wed Feb 18, 2015 8:29 am

Re: printer settings will not update

Mon Jan 28, 2019 9:35 am

You may need to update the printer's firmware in order for the machine to know it's able to travel that far. I'm not sure where the documentation for this process is stored anymore as PrintrBot no longer is in business. Hopefully another user here has done such an upgrade and may be able to help.

reberts1
Posts: 1
Joined: Wed May 25, 2016 4:06 pm

Re: Settings will not update - PrintrBot Simple Metal

Sun Feb 24, 2019 9:42 am

Yes, you will have to update your firmware and then update the Process in the Gcode tab as well.
Here are my current Printrbot Simple Metal settings for an upgrade X axis and Z axis machine (x 10 y 6 z 10 in);

Attempting connection at \\.\COM3...
Testing plaintext communication protocol...
READ: start
Connected to machine!
READ: echo:PowerUp
PowerUp
READ: Brown out Reset
READ: Marlin 1.0.0
READ: echo: Last Updated: Aug 20 2014 12:18:54 | Author: (lwalkera, Printrbot firmwarok
Active Extruder: 0
endstops hit: X:0.04 Z:1.14
Active Extruder: 0
Emergency stop issued! Attempting to reconnect...
Total build time: 15.12 minutes
Disconnected.
Attempting connection at \\.\COM3...
READ: ok
Connected to machine!
READ: ok
READ: ok T:225.0 /225.0 B:0.0 /0.0 T0:225.0 /225.0 T1:23.4 /0.0 T2:41.2 /0.0 @:47 B@:0
Active Extruder: 0
endstops hit: X:0.03 Z:1.14
Active Extruder: 0
Total build time: 160.49 minutes
endstops hit: X:0.01 Z:1.13
Active Extruder: 0
Stored settings retrieved
Steps per unit:
M92 X80.00 Y80.00 Z2020.00 E94.50
Maximum feedrates (mm/s):
M203 X125.00 Y125.00 Z5.00 E14.00
Maximum Acceleration (mm/s2):
M201 X2000 Y2000 Z30 E10000
Acceleration: S=acceleration, T=retract acceleration
M204 S3000.00 T3000.00
Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
Home offset (mm):
M206 X0.00 Y0.00 Z0.00
PID settings:
M301 P22.20 I1.08 D114.00
Min position (mm):
M210 X0.00 Y0.00 Z0.00
Max position (mm):
M211 X250.00 Y150.00 Z250.00
Bed probe offset (mm):
M212 X25.00 Y0.00 Z-0.40
Stored settings retrieved
Steps per unit:
M92 X80.00 Y80.00 Z2020.00 E94.50
Maximum feedrates (mm/s):
M203 X125.00 Y125.00 Z5.00 E14.00
Maximum Acceleration (mm/s2):
M201 X2000 Y2000 Z30 E10000
Acceleration: S=acceleration, T=retract acceleration
M204 S3000.00 T3000.00
Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
Home offset (mm):
M206 X0.00 Y0.00 Z0.00
PID settings:
M301 P22.20 I1.08 D114.00
Min position (mm):
M210 X0.00 Y0.00 Z0.00
Max position (mm):
M211 X250.00 Y150.00 Z250.00
Bed probe offset (mm):
M212 X25.00 Y0.00 Z-0.40

Return to “Troubleshooting and Bug Reports”