waterbornewarrio
Posts: 10
Joined: Sat May 12, 2018 1:23 pm

fine edge "extensions"

Fri Apr 19, 2019 12:18 pm

My parts have a fine vertical edge, and I just started to experience this problem. It may be model specific, as it shows up on some models and not others, but the models seem fine. Interestingly, it's happening in both S3D 4.0.1 and 4.1.2, but differently (the extensions are in different places when the same model is sliced). I'll try to attach a screen shot that is a close-up of the issue, and factory files for both a "smooth" edge and a "rough" edge with the extensions.
Attachments
trailing-edge-smooth.factory
(1.02 MiB) Downloaded 39 times
trailing-edge-rough.factory
(1.2 MiB) Downloaded 42 times
trailing-edge-extensions.png

waterbornewarrio
Posts: 10
Joined: Sat May 12, 2018 1:23 pm

Re: fine edge "extensions"

Fri Apr 19, 2019 12:38 pm

When I slice the model shown in "trailing-edge-rough" with different settings (for a different printer and material), the edge comes out smooth. So it may be some S3D setting or combination of settings? The attached factory file "trailing-edge-smooth-2" has the same model used in "trailing-edge-rough."
Attachments
trailing-edge-smooth-2.factory
(1.19 MiB) Downloaded 39 times

waterbornewarrio
Posts: 10
Joined: Sat May 12, 2018 1:23 pm

Re: fine edge "extensions"

Mon Apr 22, 2019 1:06 pm

I've tried to find a setting that eliminates this issue. No luck so far, but changing extrusion width has a significant effect. I normally use 0.72 (with a 0.6 nozzle), which results in many "extensions," but at 0.6 there are only a couple. Attached screen shots show the same model, sliced with identical settings except these extrusion widths. FYI, changing from manual to auto doesn't help.
Attachments
extensions-width-72.png
extensions-width-60.png

wirlybird
Posts: 1142
Joined: Sun Jul 17, 2016 1:32 pm

Re: fine edge "extensions"

Mon Apr 22, 2019 1:11 pm

I think what you have is a thin "knife" edge that won't show unless the line width is thin enough.
Try to keep lowering the extrusion width to see how it reacts. My be it the lower you go the more of that edge will show up as printable.

tonyno
Posts: 164
Joined: Sat Jan 31, 2015 5:46 pm

Re: fine edge "extensions"

Mon Apr 22, 2019 8:21 pm

Looks like you should look at Advanced, Single Extrusions, Endpoint Extension Distance. It may be zero for the one you like.

S3D-Jake
Posts: 534
Joined: Wed Jun 20, 2018 12:45 pm

Re: fine edge "extensions"

Tue Apr 23, 2019 12:02 pm

The one he likes has single extrusions turned off entirely.
tonyno wrote:
Mon Apr 22, 2019 8:21 pm
Looks like you should look at Advanced, Single Extrusions, Endpoint Extension Distance. It may be zero for the one you like.
waterbornwarrio,

Can you try setting the internal and external single extrusion type to "Perimeters only"? This should give you very similar toolpaths to what you're seeing in your "smooth" factory file.
"A bird does not sing because it has an answer. It sings because it has a song."

waterbornewarrio
Posts: 10
Joined: Sat May 12, 2018 1:23 pm

Re: fine edge "extensions"

Mon Apr 29, 2019 4:45 pm

Thanks for the replies. It looks like setting External Thin Wall Type to Perimeters Only fixes this.

Return to “Troubleshooting and Bug Reports”