jmaurin
Posts: 6
Joined: Fri Jun 30, 2017 10:07 pm

Dual Color - Doesn't retract

Sun May 19, 2019 1:15 pm

Hi.

I'm trying to use dual color with S3d, but I can't get it to work. I've done dual color wizard and it's working fine. I'm using dual extruder with single nozzle and the distance to retract is 90mm (I'm using an 'Y').
The print starts fine and after first color, the extruder 1 retracts, then extruder2 extrude 89mm (i'm using -1mm as 'Toolchange extra restart distance') and start secon color.....this is working fine and no problem at all....the problem is when printer try to go back to color 1 (extruder 1) again! The second extruder doesn't retract-back 90mm and the first extruder starts extruding, jamming both filaments in 'Y'. In the GCode I can see the retract code for both extruders and looks fine......but it doesn't work!
What am I doing wrong?
My printer is a custom CoreXY running smoothieware. I've setup both extruders in firmware and I can see/extrude/retract both extruders using Octoprint without any problem. (T0 and T1).

This is my Toolchange script:

Code: Select all

; Start Tool Change
{IF OLDTOOL=1}{IF NEWTOOL=0}G92 E0.0000
{IF OLDTOOL=0}{IF NEWTOOL=1}G92 E0.0000
{IF OLDTOOL=1}{IF NEWTOOL=0}G1 E-[toolchange_retract_distance] F[toolchange_retract_speed]	; retract old tool
{IF OLDTOOL=0}{IF NEWTOOL=1}G1 E-[toolchange_retract_distance] F[toolchange_retract_speed]	; retract old tool
T[new_tool]
{IF OLDTOOL=1}{IF NEWTOOL=0}G1 X[next_position_x] Y[next_position_y] Z[next_position_z] F[travel_speed]
{IF OLDTOOL=0}{IF NEWTOOL=1}G1 X[next_position_x] Y[next_position_y] Z[next_position_z] F[travel_speed]
{IF OLDTOOL=1}{IF NEWTOOL=0}G92 E0.0000
{IF OLDTOOL=0}{IF NEWTOOL=1}G92 E0.0000
{IF OLDTOOL=1}{IF NEWTOOL=0}G1 E[toolchange_prime_distance] F[toolchange_retract_speed]	; un-retract new tool
{IF OLDTOOL=0}{IF NEWTOOL=1}G1 E[toolchange_prime_distance] F[toolchange_retract_speed]	; un-retract new tool
; End Tool Change
This is the model that I'm testing: https://www.thingiverse.com/thing:2498345

And the generated code is attached.
Attachments
DualColorTest.gcode
(1.61 MiB) Downloaded 37 times

horst.w
Posts: 778
Joined: Fri Oct 17, 2014 5:00 pm

Re: Dual Color - Doesn't retract

Sun May 19, 2019 2:29 pm

Gcode line 175 ...

; mergeAllIntoSolid,0
; onlyRetractWhenCrossingOutline,1 <<<<<<<<< disable this setting may help
; retractBetweenLayers,1

horst.w
GER

jmaurin
Posts: 6
Joined: Fri Jun 30, 2017 10:07 pm

Re: Dual Color - Doesn't retract

Sun May 19, 2019 5:46 pm

horst.w wrote:
Sun May 19, 2019 2:29 pm
Gcode line 175 ...

; mergeAllIntoSolid,0
; onlyRetractWhenCrossingOutline,1 <<<<<<<<< disable this setting may help
; retractBetweenLayers,1

horst.w
GER
Not, still doesn't working.... it's not even related, but I've tested anyway and still doesn't work.

I think it's something wrong with S3d (maybe a bug?), because after first layer (if I push/pull fillament manually), all other layers works fine.....EXCEPT when model swap colors again (you can see the model in first post), then printer got confused again and doesn't retract one extruder before extrude another one.

jmaurin
Posts: 6
Joined: Fri Jun 30, 2017 10:07 pm

Re: Dual Color - Doesn't retract

Sun May 19, 2019 5:48 pm

Factory and profile attached.
Attachments
CoreXY Jonis - Dual Color.fff
(14.86 KiB) Downloaded 24 times
Test.factory
(7.53 KiB) Downloaded 40 times

horst.w
Posts: 778
Joined: Fri Oct 17, 2014 5:00 pm

Re: Dual Color - Doesn't retract

Mon May 20, 2019 4:39 am

Opening your factory file it shows a cube. Ok.
Prepare to Print shows additionally the activated Prime Pillar. Ok.

Beside your problem it may be a temperature missmatch with the 2nd color process also for your single-nozzle-dualextruder ???

The Vertical Lifts are set to zero (0).

Looking to the gcode I find the first tool change clearly with retract:
...
; Start Tool Change
G92 E0.00
G1 E-110.0000 F2100 ; retract old tool
M400
T1
G1 X167.210 Y149.210 Z0.160 F7800
G92 E0.00
G1 E109.5000 F2100 ; un-retract new tool
M400
; End Tool Change
; feature prime pillar
G1 X167.210 Y149.210 F7800
G92 E0.0000

The retract is set to 5 mm and I have no idea from where "E-110" is comming.

The conditions for settings of a single nozzle - dual extruder I dont know. A member of the german RepRap-forum has build a 5-color -single-nozzle-extruder and it is running fine.



H.
DualColor-A.png
Attachments
DualColor-B.png

jmaurin
Posts: 6
Joined: Fri Jun 30, 2017 10:07 pm

Re: Dual Color - Doesn't retract

Mon May 20, 2019 6:36 am

horst.w wrote:
Mon May 20, 2019 4:39 am
Opening your factory file it shows a cube. Ok.
Prepare to Print shows additionally the activated Prime Pillar. Ok.

Beside your problem it may be a temperature missmatch with the 2nd color process also for your single-nozzle-dualextruder ???

The Vertical Lifts are set to zero (0).

Looking to the gcode I find the first tool change clearly with retract:
...
; Start Tool Change
G92 E0.00
G1 E-110.0000 F2100 ; retract old tool
M400
T1
G1 X167.210 Y149.210 Z0.160 F7800
G92 E0.00
G1 E109.5000 F2100 ; un-retract new tool
M400
; End Tool Change
; feature prime pillar
G1 X167.210 Y149.210 F7800
G92 E0.0000

The retract is set to 5 mm and I have no idea from where "E-110" is comming.

The conditions for settings of a single nozzle - dual extruder I dont know. A member of the german RepRap-forum has build a 5-color -single-nozzle-extruder and it is running fine.



H.
DualColor-A.png
This code is fine, this is the retract for fillament change. I can't get even the prime pillar in dual color in my S3d :/ it shows only one color (cube shows two color fine).

horst.w
Posts: 778
Joined: Fri Oct 17, 2014 5:00 pm

Re: Dual Color - Doesn't retract

Mon May 20, 2019 7:50 am

jmaurin wrote:
Mon May 20, 2019 6:36 am

... I can't get even the prime pillar in dual color in my S3d :/ it shows only one color (cube shows two color fine).

??? I only have open your factory file without changing anything and it shows in the Print Preview the Prime Pillar as 2-colored.
But I would expect to see this as only one tower, printed as bands alternating color1 and color2.

H.
Attachments
DualColor-B.png

markostamcar
Posts: 2
Joined: Sun Jun 16, 2019 6:39 pm

Re: Dual Color - Doesn't retract

Sun Jun 16, 2019 6:40 pm

I'm having the same issue - 2 prime towers instead of just 1 interlaced. Seems like this was introduced in a recent update?

Return to “Troubleshooting and Bug Reports”