mrKayne
Posts: 1
Joined: Tue Sep 17, 2019 11:32 am

S3D 4.1 crashes on launch

Tue Sep 17, 2019 11:40 am

Hi!

I've also asked the support directly for help, but until they respond, I might aswell try my luck here.

I'm running Win10 Pro 64bit, freshly updated.

When I run the program, it just freezes up right away with a white screen. It gives me no errors or anything.
I tried to reboot, reinstall and also tried to clear the AppData S3D folder as suggested in an other thread, but no luck.

So... any of you guys have an idea?

Thanks!

PaulK
Posts: 2
Joined: Sun Oct 13, 2019 12:53 am

Re: S3D 4.1 crashes on launch

Sun Oct 13, 2019 1:29 am

I'm also got the same problem.

Win 10 Pro, 64 bit, S3D 4.1.2, opens to a white screen and then stops responding.

nogarth
Posts: 4
Joined: Mon Oct 14, 2019 1:08 pm

Re: S3D 4.1 crashes on launch

Mon Oct 14, 2019 1:24 pm

Yup same issue here windows 10 Pro latest verions on all.

to fix have to delete

REG KEY

HKEY_CURRENT_USER\Software\Simplify3D

PaulK
Posts: 2
Joined: Sun Oct 13, 2019 12:53 am

Re: S3D 4.1 crashes on launch

Tue Oct 15, 2019 11:01 pm

Thank you - that fixed the problem.

arhi
Posts: 447
Joined: Thu Oct 06, 2016 5:13 pm

Re: S3D 4.1 crashes on launch

Wed Oct 16, 2019 9:00 am

if you delete WHOLE registry that will kill your settings and everything else :( .. not a very good solution

try to delete only GEOMETRY keys

so
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\Communicator\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\FFFWindow\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\MainWindow\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\SectionDialog\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\SplitProcessDialog\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\SupportGeneration\geometry

and see if it will fix the problem

these keys only keep "Where did you left your window open last time"

the problem is, windows 10, if you move your s3d window to the non-primary screen (assuming you have multiple monitors) and close it, next time it will try to open on that non-primary screen and it will freeze. it is a wxwidget bug: https://trac.wxwidgets.org/ticket/18532

please try if that works for you... to freeze s3d again move it to non primary screen and exit s3d, next time you start it will try to load on that same screen and it will freeze ... delete the geometry keys and it will work again.

this bug is also reported here: viewtopic.php?p=52776
gcodestat integrates with Simplify3D and allow you to
Calculate print time accurately (acceleration, max speed, junction deviation all taken into consideration)
Embed M117 codes into G-Code
Upload your G-Code directly to Octoprint
open source and unlicence

nogarth
Posts: 4
Joined: Mon Oct 14, 2019 1:08 pm

Re: S3D 4.1 crashes on launch

Thu Mar 05, 2020 5:52 pm

this happened again to me after GFX card update drivesr. so i followed OP and it worked just the geo reg entrys. thanks

arhi
Posts: 447
Joined: Thu Oct 06, 2016 5:13 pm

Re: S3D 4.1 crashes on launch

Thu Mar 05, 2020 11:33 pm

nogarth wrote:
Thu Mar 05, 2020 5:52 pm
this happened again to me after GFX card update drivesr. so i followed OP and it worked just the geo reg entrys. thanks
can you share your hardware ? you have nvidia and windows10?
this looks like nvidia issue on windows 10, I have this identical bug with slic3r, netfabb and bunch of other software
gcodestat integrates with Simplify3D and allow you to
Calculate print time accurately (acceleration, max speed, junction deviation all taken into consideration)
Embed M117 codes into G-Code
Upload your G-Code directly to Octoprint
open source and unlicence

snlink6
Posts: 1
Joined: Wed Mar 11, 2020 8:45 pm

Re: S3D 4.1 crashes on launch

Wed Mar 11, 2020 10:45 pm

having the exact same issue, and sadly the S3d support site ticket system seems to be down, i'm unable to even send in a ticket for support

S3d 4.1 crashing on launch

-I get a white screen crash every time I attempt to open S3d.
I have uninstalled and reinstalled the latest version, but no change.

The only thing I've tried that has worked was a regedit deletion of the regestery keys for S3d from current_user, but that only works until I start S3d again.
HKEY_CURRENT_USER\Software\Simplify3D

Windows 10 x64 bit - updated
s3d 4.1 updated
Nvidia geforce 2080 drivers - updated

arhi
Posts: 447
Joined: Thu Oct 06, 2016 5:13 pm

Re: S3D 4.1 crashes on launch

Fri Mar 13, 2020 7:35 am

more than one monitor? cpu? amd or intel? this I started having after I moved from win7 intel to win10 amd ryzen .. same nvidia card... it's a bug in nvidia driver, not in s3d, you do not have to delete whole registry, just all the "geometry" keys

HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\Communicator\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\FFFWindow\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\MainWindow\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\SectionDialog\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\SplitProcessDialog\geometry
HKEY_CURRENT_USER\Software\Simplify3D\S3D-Software\SupportGeneration\geometry

on dual monitor issue is if you leave your s3d window on non primary monitor it stores the location to open it there next time (in those registry keys), when you try to open the app on non primary monitor nvidia shit it's pants: https://www.nvidia.com/en-us/geforce/fo ... apbuffers/
gcodestat integrates with Simplify3D and allow you to
Calculate print time accurately (acceleration, max speed, junction deviation all taken into consideration)
Embed M117 codes into G-Code
Upload your G-Code directly to Octoprint
open source and unlicence

oftebro
Posts: 1
Joined: Wed Mar 25, 2020 12:55 pm

Re: S3D 4.1 crashes on launch

Thu Mar 26, 2020 11:31 am

I tried the RegEdit and deleting all the Geometry items and it didn't work for me.

I got this info from Simplify Support. Worked great!!

"Thank you for your e-mail. I am happy to help.

Could you please try navigating to your Simplify3D working directory (likely at C:/Users/%USERNAME%/AppData/Local/Simplify3D/S3D-Software) and deleting the savedState.factory file? This is what loads the previous state when launching the program, so if something too large was saved, or if the file got corrupted, this could cause the failure to launch that you are seeing"


Thanks to the community and Simplify Support!!

Return to “Troubleshooting and Bug Reports”