JasonJMP
Posts: 2
Joined: Thu Dec 22, 2016 9:49 am

Re: S3D 4.1 crashes on launch

Mon Aug 17, 2020 9:50 am

Same issue. I have multiple monitors. Deleting geometry fixed it!

Thanks!

TechGuy107
Posts: 1
Joined: Fri Oct 16, 2020 1:19 am

Re: S3D 4.1 crashes on launch

Fri Oct 16, 2020 1:56 am

Hi,

I can can confirm this issue still occurs with Simplify3d version 4.1.2. This is how I fixed it on Windows 10.

Like many others, removing geometry keys fixes it only until the next launch. This is a bug which occurs for people who have more than 1 monitor.
I traced the trouble back to a Nahimic feature called "Sound Tracker Engine".

While troubleshooting, I discovered that the trouble went away if the Nahimic service is disabled in Windows services. If you use the Nahimic service, it can remain enabled for this fix.

- I updated Nahimic from the Windows Store, but the issue persisted (this step may or may not be needed).

- I updated my optional Intel drivers from the Windows Update optional downloads because Nahimic was telling me my sound drivers were outdated. (this step may or may not be needed)

- I went into Nahimic -> Settings -> Sountracker Engine and disabled it. This seems to have fixed my Simplify3D crash on launch troubles.
Hopefully this helps Simplify3d and others fix this Simplify3d 4.1.2 bug.

Thanks.

GR8YT
Posts: 2
Joined: Sat May 30, 2020 12:29 pm

Re: S3D 4.1 crashes on launch

Sat Oct 17, 2020 9:01 pm

After trying everything suggested here and elsewhere, I still could not get Simplyfy3D or several other programs to start. In Windows 10 Event viewer/Application it always showed an "unknown error" event 1000.

I fixed my issue by disabling the “Intel UHD Graphics 630” adapter. Open Device Manager, select Display Adapters, right click, and “disable” the adapter. DO NOT select “uninstall device”, it will automatically re-install itself, just disable it.

If you are having the same issue with programs not starting after Microsoft’s Windows 10 October 2020 update, you may not have the exact same adapter as listed above but it was the UHD Graphics adapter causing my problem – ok, not so much the adapter as whatever they messed up in the latest update for the graphics drivers.

ChoreBoy
Posts: 4
Joined: Wed Apr 29, 2015 8:44 am

Re: S3D 4.1 crashes on launch

Thu Oct 29, 2020 3:04 pm

I just used this solution and it worked for me. Thanks for posting!
oftebro wrote:
Thu Mar 26, 2020 11:31 am
I tried the RegEdit and deleting all the Geometry items and it didn't work for me.

I got this info from Simplify Support. Worked great!!

"Thank you for your e-mail. I am happy to help.

Could you please try navigating to your Simplify3D working directory (likely at C:/Users/%USERNAME%/AppData/Local/Simplify3D/S3D-Software) and deleting the savedState.factory file? This is what loads the previous state when launching the program, so if something too large was saved, or if the file got corrupted, this could cause the failure to launch that you are seeing"


Thanks to the community and Simplify Support!!

Mark Stafford
Posts: 1
Joined: Tue Nov 03, 2020 4:57 pm

Re: S3D 4.1 crashes on launch

Tue Nov 03, 2020 5:07 pm

Hi All,
I tried all of the suggestions above - no joy.

After some experimentation I found that this issue occurs on a multi-monitor setup when the Simplify3D application is located on a non-primary monitor and it is then closed.

If you delete the geometry property in the HKCU:\Software\Simplify3D\S3D-Software\MainWindow key then the application starts successfully and the app main window appears in the primary monitor.

If you close the app while it is in the primary monitor you can reopen the application successfully.

If you move the app to a non-primary monitor and then close it - it hangs on opening.

I hope this helps.
regards
Mark

Return to “Troubleshooting and Bug Reports”