joesoap583
Posts: 99
Joined: Sat Mar 08, 2014 11:01 pm

Incorrect Action When Purging Filament

Sun Sep 22, 2019 12:15 pm

During the startup script I like to purge material by issuing a G1 E25 F300 instruction. However more often than not when S3D executes that command the extruder unloades filament and I end up with several 10's of mm filament missing. Frequently this follows a previous print where the purge operation worked as intended, so I'm puzzled about why this isn't a robust operation.

I haven't managed to figure out why this is happening - can someone help?
Posting as a private individual - 3D printing is a hobby activity.
Creality CR-10S owner.

HabaaZ
Posts: 3
Joined: Thu Sep 26, 2019 9:14 am

Re: Incorrect Action When Purging Filament

Thu Sep 26, 2019 9:23 am

I have this problem to on my Powerspec Ultra 2.0 also. After the initial wipe script the filament backs up at least a centimeter and this prevents starting of the skirt and if the part is small the first layer of the part. I cant find anywhere in the script that would make this happen. My fix is to manually advance the filament after the wipe while its printing the skirt.

horst.w
Posts: 852
Joined: Fri Oct 17, 2014 5:00 pm

Re: Incorrect Action When Purging Filament

Fri Sep 27, 2019 6:20 am

Question:
what mode do you use? Relative or Absolut?

please attache your starting script.

horst.w
GER

HabaaZ
Posts: 3
Joined: Thu Sep 26, 2019 9:14 am

Re: Incorrect Action When Purging Filament

Thu Oct 03, 2019 10:31 am

M907 X100 Y100 Z40 A100 B100 ; Set motor current
G28 ; Home axes
M612 X35.0 Y0.0 ; Set toolhead offsets
M108 T0 ; Change to right extruder
M132 X Y Z A B ; Recall home offsets
G1 Z100 F3300 ; Lower Z
G1 X-110.5 Y-72 F6000 ; Move to wait position
M7 ; Wait for bed to stabilize
M6 T0 ; Wait for right extruder to reach target temp
G1 X-100 Y-72 F9000 ; Move to front left corner of bed
G1 Z0.3 F6000 ; Move down to purge
G92 E0 ; Zero extruders
G1 X90 Y-72 E24 F2000 ; Extrude a line of filament across the front edge of the bed
G1 X100 Y-72 F180 ; Wait for ooze
G1 X110 Y-72 F5000 ; Fast wipe
G1 Z1 F100 ; Lift

This is the starting script. Simplify put it in automatically. I am just starting to learn G-codes

HabaaZ
Posts: 3
Joined: Thu Sep 26, 2019 9:14 am

Re: Incorrect Action When Purging Filament

Thu Oct 03, 2019 10:34 am

It looks like 'absolute' values because the relative box is not checked.

S3D-Alex
Posts: 441
Joined: Thu Aug 30, 2018 1:23 pm

Re: Incorrect Action When Purging Filament

Fri Oct 04, 2019 8:34 am

HabaaZ wrote:
Thu Oct 03, 2019 10:34 am
It looks like 'absolute' values because the relative box is not checked.
Can you please go into the Process Settings for your printer and under the G-Code tab check the box labeled 'Allow zeroing of extrusion distances (i.e. G92 E0)'? This should ensure the printer zeros the extruder before printing.

Return to “Troubleshooting and Bug Reports”