danie
Posts: 2
Joined: Wed Oct 30, 2019 9:29 am

Retraction doesn't work

Wed Oct 30, 2019 9:32 am

Hello,
My DELTA printer's extruder retraction doesn't work.

I't meanse

First, my printer has this problem.
- retraction fail.

When it works retraction since printing something,
Step motor must work push- rewind fast - push right?
my printer work push- push fast - push
it' cannot rewind the filament.

I switched motor driver, step motor and reset firmware.

But it still cannot rewind the filament.

What should I do?
I need your guys opinions. Cause I believe you guys better than me.
Please help me.

horst.w
Posts: 811
Joined: Fri Oct 17, 2014 5:00 pm

Re: Retraction doesn't work

Wed Oct 30, 2019 11:46 am

Hi,
other functions backwards are running? (manual movement extruder back, filament changing ?)

retraction distance, other than zero in tab extruder of the setting window is set?

machine type is right? - delta robot.


horst.w
GER

danie
Posts: 2
Joined: Wed Oct 30, 2019 9:29 am

Re: Retraction doesn't work

Wed Oct 30, 2019 12:03 pm

horst.w wrote:
Wed Oct 30, 2019 11:46 am
Hi,
other functions backwards are running? (manual movement extruder back, filament changing ?)

retraction distance, other than zero in tab extruder of the setting window is set?

machine type is right? - delta robot.


horst.w
GER
I uploaded made a video on youtube
https://youtu.be/tTrv_9Rx4KE
Please check this first.

Manual movement have problem too. only work forward. push forward-> work forward, push backward->work forward !!
Machine type is delta
First, I was suspected at slicer problem, gCODE..something wrong with that. But It was not.
I used cura3.0, cura 4.3, and simplify3D. And even I'm using other delta printer too. It's still fine!.

horst.w
Posts: 811
Joined: Fri Oct 17, 2014 5:00 pm

Re: Retraction doesn't work

Thu Oct 31, 2019 6:48 pm

It sounds like a gear is sliping on its axis or a ball bearing blocs.

I can only say what I would try out:

- testing motors movement forward and backward without filament (empty). Next step

- testing the extruder with filament but without a nozzle.

Surely most users here have experiences also with hardware, but this is the forum of a slicer software.
I'm coming from the german section of reprap-forum and there are a lot of specialists hardware and software and DIY deltas included. If you want to ask there, english is no problem: https://reprap.org/forum/list.php?252

H.

Return to “Troubleshooting and Bug Reports”