Posts: 25
Joined: Sat Oct 04, 2014 9:09 pm

GCode Z-height isn't working

Sat May 02, 2020 9:43 pm

I'm running a Cocoon Create (I3 clone) with a Bigtreetech SKR V1.3 32 bit board, and a BLTouch.
I'm trying to get the right starting offset for the first layer by entering the Z-offset height in the GCode tab. Nothing I've tried seems to make the slightest difference, it's still running the nozzle hard against the platform from 0.0 mm offset up to my latest try at a full 6.0 mm !!
Do I need to do anything with the Z-offset setting from the control panel on the box itself as well? It was on -0.61 mm when I was trying different GCode offsets but nothing seemed to work so I reset it to 0.0 mm. I've got it doing a G29 in nine places to check for varying heights.
I've tried this page - ... -of-print/ - with zero effect.

Any suggestions please?

Edit - Here's a screen capture after a G28. Before the G28 I warmed the nozzle & platform, then manually put the nozzle at the right height (a thin sheet of paper) above the platform, then zeroed the Z-height position right there.

Return to “Troubleshooting and Bug Reports”