Posts: 5
Joined: Tue Jul 09, 2019 8:17 pm

Prime after filament change

Wed May 27, 2020 10:27 pm

Hi S3D community,

I have spent 2 days on this so any help is greatly appreciated. If I am missing something then I am happy to admit my mistake, learn from it, correct it and move on.

I need help printing with two colors out of one nozzle - I have a pause to change filament in the tool change script.

The trouble I am facing is finding a way to prime the second filament after the pause.

Prime pillars don't print the same as the parts when there are two tools. I have two parts stacked on top of each other, each with a separate process. I add a prime pillar and then step through the simulation line by line. The prime piller prints at a different height than the print. The outward symptom when trying to print is that the prime tower doesn't stick. every other part and print I do, including a skirt on the same print, will stick perfectly. I wrestled with this for several hours and couldn't find a way around it so I gave up on that.

My second idea was to use a skirt. When I put a skirt on the bottom part and render only the bottom part, the skirt is there. When I render both parts, the skirt for the top part no longer shows up in the simulation. If I add a skirt for the upper part then that skirt is shown on the bed. After several hours I gave up on this also.

My last resort is that I added my own parts (two disks stacked up) to act as prime pillars.

This almost works, the problem is that no matter what I try, the upper layer prints before the prime disk for that layer I tried with separate processes for the disks, I tried layer by layer in the same process. I tried setting the starting coordinates for the layer. nothing I can think of seems to make it print the disk first.

I am at a loss. I have really tried to figure this out on my own, but I am going in circles now.

Any ideas area so greatly appreciated!

Posts: 7
Joined: Wed Mar 25, 2020 2:34 pm

Re: Prime after filament change

Tue Sep 01, 2020 10:01 am

Did you get any help on this issue?

Return to “Troubleshooting and Bug Reports”