ceondraka
Posts: 17
Joined: Tue Jul 09, 2019 12:58 pm

Extra Lines Added (BUG)

Tue Jun 30, 2020 9:09 pm

S3dBug2.JPG
See the image above that shows some extra external single extrusion "Triangles" have been added to the top internal layer. They do not exist in the model that I designed in Fusion360. Went to Preview it and there they are. And it prints them. So why are they there??

I tried to find something in the forum but could not find an exact hit.

Here's what caused it. I can make them appear and disappear. This to me is a bug.
I have attached the .STL file in the picture and also the FFF Settings File.

I have an uneven bed so I added a Global G-Code Offset Z-Axis = 0.1 to lift everything a little higher.
I am using a layer height of .2mm.
So to compensate for the added height .2mm + .1mm = .3mm first layer height, I changed the First Layer Height to 150%. .3/.2 = 1.5.
I also have First layer Width at 110% but changing this value does not correct the issue above.
So when I do this and have a exact ratio the little triangles in the picture appear.
BUT.....
If I change the First Layer Height to 149% or 151% the problem goes away and the little triangles go away and do not print.

Changing the Global Z-Offset back to zero does not change anything so it appears it's a ratio problem with layer height and First Layer Height.

So another test.....
Changing layer height to .15 the First Layer Height at 150% and the problem does not appear.
Staying with Ratio's I enter .15 Layer Height and 200% First Layer Height and still no problem.

Can't figure out what' Ratio is causing the phantom lines to appear.

Anyone got an idea?

Thanks.
Attachments
TL_Smoother-Bottom.stl
(68.25 KiB) Downloaded 37 times
[PLA+001]-SM1_PLA_Plus-(MedQ).fff
(12.14 KiB) Downloaded 31 times

gearsawe
Posts: 150
Joined: Sun Sep 10, 2017 11:06 pm

Re: Extra Lines Added (BUG)

Wed Jul 01, 2020 3:32 am

My experience with STL files. They are not exact. There are floating point issues when models are exported to an STL.
here is the hole where the problem is. Notice one edge is ever so slightly longer?
RoundingError.png
S3D is seeing this little piece of geometry sticking up and doing exactly what it should do... unfortunately in your case.

I have seen this quite often. Some programs export better then others.
the problem creeps up more often when you design in the same thickness as multiple of your layer heights.
So not really a bug in this case.

The other thought is this sometimes does not show up in other slicers because they will round the the values of the mesh to the nearest 0.0001mm. which is still plenty of accuracy. This too can cause other problems.

Return to “Troubleshooting and Bug Reports”