Page 1 of 1

Auto-Leveling Mesh Issue

Posted: Wed May 05, 2021 3:40 pm
by Justin4594
Hello! I am new to the Simplify3D realm (coming from Cura) and am excited about all the new features Simplify3D offers. However, I am trying to perform my first print with Simplify3D generated g-code and am running into an issue where the auto-leveling procedure runs (and appears to work) but the mesh is not being used when printing. I am using a Geeetech A20M equipped with a BLtouch sensor to auto-level my bed. When using Cura, I have no issues. For S3D, when printing the purge line, the Z axis clearance is fine when it starts, but by the time it makes it to the other side it is almost eating into the bed. Fortunately, I watch my prints closely in the beginning and was able to stop it before any damage was done. I am just wondering what it is that I am missing. Any help would be greatly appreciated!

Summarized Info

Auto-Level Running but generated mesh not appearing to be utilized (causing large z-axis print variations)

Z-Offset was calibrated and set in the printer's firmware, not in S3D nor in Cura

Starting code used in Cura that works:

Code: Select all

G28 ;home
G90 ;absolute positioning
M280 P0 S160 ; BLTouch alarm release
G4 P100 ; delay for BLTouch
G28 ; home
G29 ; auto bed leveling
G1 X0 Y0 Z15 E0 F300 ;go to wait position
M140 S60 ;set bed temp
M109 S200 ;set extruder temp and wait
G1 Z0.8 F200 ;set extruder height
G1 X220 Y0 E80 F1000 ;purge line
;end of start script
Starting Code used in Simply3D not working:

Code: Select all

G90
M82
M106 S0
G28 ; home all axes
G90 ;absolute positioning
M280 P0 S160 ; BLTouch alarm release
G4 P100 ; delay for BLTouch
G28 ; home
G29 ; auto bed leveling
M205 X10 Y10 ; set XY jerk to 10
M163 S0 P1.0
M163 S1 P0.0
M164 S0 ; set T0 mixing ratio to full right
M163 S0 P0.0
M163 S1 P1.0
M164 S1 ; set T1 mixing ratio to full left
M163 S0 P0.5
M163 S1 P0.5
M164 S2 ; set T2 mixing ratio to even mix
T0 ; select full right extruder
G1 X15 Y10 Z0.3 F3000 ; avoid binder clips
M140 S60 T0
M190 S60 T0
M104 S200 T0
M104 S200 T1
M109 S200 T0
M109 S200 T1
G1 X195 E15 F500 ; prime line
G1 X205 F100 ; slow wipe
*Note: Both Codes listed above were taken directly out of exported g-code files for comparison, not from the starting script dialog boxes

Image of failed purge line also attached (thicker line on left and thinner on right as nozzle goes into bed without utilizing mesh to compensate)