smartavionics
Posts: 52
Joined: Fri Oct 24, 2014 3:46 am

2.2.1 libInteface.so has bad permissions on 32 bit Linux

Sat Jan 10, 2015 2:48 am

The install script leaves libInterface.so in the 32 bit Linux 2.2.1 release with the wrong file permissions.

You need to chmod 755 /opt/Simplify3D-2.2.1/libInterface.so otherwise s3d will not run.

JoeJ
Posts: 1435
Joined: Sun Feb 16, 2014 10:52 am

Re: 2.2.1 libInteface.so has bad permissions on 32 bit Linux

Sat Jan 10, 2015 5:42 am

I have seen this before too, but re-downloading and re-installing fixed it. Try re-downloading from their website. It seems to be fine for me.

smartavionics
Posts: 52
Joined: Fri Oct 24, 2014 3:46 am

Re: 2.2.1 libInteface.so has bad permissions on 32 bit Linux

Sat Jan 10, 2015 8:06 am

The download I have definitely has a problem, I haven't tried re-downloading again but if you say it's now fixed, they must have (silently) updated it.

Return to “Troubleshooting and Bug Reports”