jwellman
Posts: 14
Joined: Thu Mar 13, 2014 11:44 am

Changing materials does not change temperature in profile

Sat Jan 17, 2015 3:32 pm

I'm using 2.2.1 but I've seen this behavior since I started with S3D about a year ago.

Essentially If you select a profile, then change the material the temperatures (and many other settings) don't seem to follow across. It would be nice if changing the material also changed settings for that material. I've made a quick video showing what I'm seeing:

https://jwellman.tinytake.com/sf/NDA1NTRfMzMwNTQ3

As it is now I have to select the material and then make a fair amount of changes to the profile to make sure everything is setup correctly. This seems to nullify the reason for having profiles in the first place.

Thanks,
Jared

User avatar
jimc
Posts: 1124
Joined: Wed Aug 28, 2013 11:02 pm
Location: mullica, nj
Contact: Website

Re: Changing materials does not change temperature in profil

Sat Jan 17, 2015 7:13 pm

your right and i have noticed this too. i havent noticed temp doing this though. my temp seems to be what i have set for ext and bed in the saved fff. i have noticed it with the infill extrusion width and a bunch of others. its funny because if you save the fff file and look at it, all the info is there but for some reason, previous settings override the imported fff.

jwellman
Posts: 14
Joined: Thu Mar 13, 2014 11:44 am

Re: Changing materials does not change temperature in profil

Sat Jan 17, 2015 7:36 pm

As you mention it does seem like all the info is there. The first switch of material seems to work. So if the profile populates with ABS selected and I want to print PLA I can choose PLA and all of the settings transfer. But if I choose ABS again then they stay the same as the PLA settings.

So as a work around it's possible to only switch the material once. Or if you need to switch it back to load another profile then load the one you wanted. Kind of a kludge but I guess it will work until/if this gets addressed.

Unfortunately I seem to switch between the two materials fairly often :-/

Jared

oscahie
Posts: 1
Joined: Fri Jan 23, 2015 8:56 pm

Re: Changing materials does not change temperature in profil

Fri Jan 23, 2015 9:01 pm

This is a very annoying bug. What actually happens is that when you export a profile, after having configured the settings for material and quality, the exported .fff file will be missing the auto-configuration settings for whatever auto-configuration options you have selected at the moment of exporting. For instance, if I have Medium quality selected and export the profile, then open the .fff with a text editor, this is what I see:

<autoConfigureQuality name="Fast">
<layerHeight>0.3</layerHeight>
<topSolidLayers>3</topSolidLayers>
<bottomSolidLayers>3</bottomSolidLayers>
<skirtLayers>1</skirtLayers>
<supportInfill>25</supportInfill>
</autoConfigureQuality>
<autoConfigureQuality name="Medium">
</autoConfigureQuality>
<autoConfigureQuality name="High">
<layerHeight>0.1</layerHeight>
<topSolidLayers>4</topSolidLayers>
<bottomSolidLayers>4</bottomSolidLayers>
<skirtLayers>2</skirtLayers>
<supportInfill>40</supportInfill>
</autoConfigureQuality>


The settings I had for 'Medium' are gone. This is with S3D 2.2.1.

Return to “Troubleshooting and Bug Reports”