Q*bert
Posts: 8
Joined: Fri Mar 08, 2013 12:32 pm

Machine control of M2 is goofy

Fri Mar 15, 2013 12:00 am

I can generate a g-code file that previews properly, but when run using the Machine Control Panel my M2 doesn't interpret the g-code properly. The M2 seems to follow some of the g-code but then runs off in strange patterns.

I can load the same Creater produced g-code file into pronterface and it runs properly. I thought it might be due to a USB communication error, but I get the same result using a different computer.

Any ideas?

Blown454
Posts: 3
Joined: Wed Mar 13, 2013 10:23 pm

Re: Machine control of M2 is goofy

Fri Mar 15, 2013 1:25 am

Try unticking the monitor box under temperature if it is on. That helped me.

Sparky
Posts: 18
Joined: Wed Mar 13, 2013 1:22 pm

Re: Machine control of M2 is goofy

Fri Mar 15, 2013 2:38 pm

Running g-code from the M2 SD with monitor ON works for me. Running g-code via USB with monitor ON appears to choke the serial pipe.

Q*bert
Posts: 8
Joined: Fri Mar 08, 2013 12:32 pm

Re: Machine control of M2 is goofy

Fri Mar 15, 2013 3:09 pm

Sparky wrote:Running g-code from the M2 SD with monitor ON works for me. Running g-code via USB with monitor ON appears to choke the serial pipe.
Wow. I know this is brand new software, but this made it through beta?

Karl_Williams
Posts: 61
Joined: Wed Mar 13, 2013 1:26 pm
Contact: Website

Re: Machine control of M2 is goofy

Fri Mar 15, 2013 3:29 pm

I think we're beta testing it right now LOL.

Sparky
Posts: 18
Joined: Wed Mar 13, 2013 1:22 pm

Re: Machine control of M2 is goofy

Fri Mar 15, 2013 5:59 pm

Another thing I noticed while trying to run g-code via USB with the monitor OFF method . . .
Turned monitor on to set temps
when temps reached set point, I turned monitor OFF, hit RUN and selected g-code file and waited and waited for several minutes. Nothing happened until I switched monitor ON. Immediately all axes homed, so I then switched monitor OFF again.
G-code began running smoothly for several minutes, but as soon as I switched monitor back on, erratic movement began again.

Simplify3D
Site Admin
Posts: 304
Joined: Sun Feb 10, 2013 8:28 pm

Re: Machine control of M2 is goofy

Fri Mar 15, 2013 8:24 pm

That's a bug that's being fixed in 1.0.4, but you actually figured out a really creative way to get around it! We think it has to do with the extra blank lines in the gcode file since the software is waiting for a response, but obviously the empty line won't give one. Toggling monitoring on and off sends a new command which gets the firmware response we were waiting for.

We have been burning the midnight oil getting 1.0.4 ready as quick as possible and hope it to be released early this coming week.

Return to “Troubleshooting and Bug Reports”