Phgeis
Posts: 21
Joined: Tue Jun 04, 2013 7:32 am

Makerbot 2x(Sailfish) Basic setup

Tue Jun 04, 2013 7:34 am

Hi could any body indicate me some direction how to initally setup all the impostations for my Rep2x(sailfish) to start from?

I mean the bsic stuff before playing around with infill and dual extrusion..Like tool number Buildplate etc.

THANX

taerog
Posts: 11
Joined: Fri May 17, 2013 2:23 pm

Re: Makerbot 2x(Sailfish) Basic setup

Wed Jun 05, 2013 11:57 am

I have a setup that works (I am at work and will post it later today)
It took a bit of tweaking as I needed to change a few G-codes under the firmware section. (manly for the heating plate)
In the profile I needed to STILL set an Gcode offset (think I used -150 -75 0 ) I was kind of surprised on this since the Gcode header now has a offset defined (second to last code - or so) Not sure what is going on there . .
Also using the new Rep2 profile provided as a basis, I needed to reduce the max X for the Rep2x. the current numbers for X on front left corner smashes the carriage. Again going on memory but I set the position ~ x 135 And wipe down from there. ie 130. The 140,145 was too much (ok for Rep 2 with -1 extruder)
Add different temperatures, Add Heatplate temps, Change GPX to Rep2x, set filament size, Change to ABS, etc

Also setting the heating plate under temperatures is either very unintuitive or bugged. I have yet to isolate the UI issue but it seems like it will complain if you use t1 or t0 for heating bed (should not matter) . . . sometimes and ok otherwise. and I got it to work setting it to t2 in the UI but it puts t1 in the Gcode. I think there is a possibility the index for the pull-down box for additional devices is off? but I have yet to really look at it - just inconsistent ATM.
Also with the same issues I have yet to get the second extruder to work correctly without manually editing the gcode.

I do not think there is any issue using sailfish (and the built in deprime - ie I have yet to run into a problem)

Disappointed on no serial support yet. I hate using the FW controls for jogging . . and find it very useful in RepG to heat up the bot, move it around and, do a test extrude . . from a good interface. My wish for the next version. (though not a must have now really)

That is all I got now

taerog
Posts: 11
Joined: Fri May 17, 2013 2:23 pm

Re: Makerbot 2x(Sailfish) Basic setup

Wed Jun 05, 2013 5:22 pm

As promised. . . note these are a work in progress.
I uploaded the firmware profile for rep2x /w sailfish (zipped it because the attachment did not like the file extension)
and the .fff profile I am working on.

Not too much but a start. I hope that helps. :D
Attachments
new-sailfish.zip
Zipped firmware profile for rep2x /w sailfish
(484 Bytes) Downloaded 442 times
makerbot_2x_abs-test.fff
.fff profile for rep2x /w sailfish
(3.44 KiB) Downloaded 625 times

Phgeis
Posts: 21
Joined: Tue Jun 04, 2013 7:32 am

Re: Makerbot 2x(Sailfish) Basic setup

Sun Jun 09, 2013 9:08 am

Hi tearog, THANXS so far.

Some questions of mine arroused.. all the last days tried to solve them myself but now I came back here, because I did not achieve anything!

1. Under options/machine/ Which axis have to be flipped? x and y as far as I understood but this brings me ayway not around my major problem right now:
rigth after the startcode (I think) the extruder gets send way of the platform (or is it the startcode?) and I have to abort the build? Why ? any Idea? used your start code: same problem!! even the simulation shows what happens!

2. You set up a new *.frm Why ? And do we have to change it anytime Jetty and Dan update?
Attachments
1.jpg
1.jpg (93.25 KiB) Viewed 8987 times

Simplify3D
Site Admin
Posts: 304
Joined: Sun Feb 10, 2013 8:28 pm

Re: Makerbot 2x(Sailfish) Basic setup

Sun Jun 09, 2013 9:45 am

The main thing to keep in mind is that the Rep2/2x use a zero position in the middle of the bed. I have a feeling your problem is coming from the fact that you are using both a G10 offset and a G-Code X/Y offset to account for this fact. The G10 offset is placed in your start gcode and it is implemented by the firmware. So for the Rep2, this might look like:

G10 P1 X-140 Y-75 ; set local offset for Creator
G54 ; enable G10 offset

That tells the firmware to apply this offset to all commands, which essentially makes gcode that ranges from 0 to +280mm in the x-direction and 0 to +150mm in the y-direction get converted to the appropriate -140 to +140 in x and -75 to +75 in y. The nice thing about doing this with the G10 offset is that the preview in Creator will still be centered on the build table and will look like normal.

An alternate way to account for the Rep2/2x center position is to use the X/Y/Z offsets on the G-Code tab of the FFF Settings dialog within Creator. This essentially modifies every X/Y/Z coordinate in your gcode or x3g file by that amount. So setting the X/Y offsets in Creator to -140/-75 would accomplish the same thing, but the preview will be shifted like yours appears to be.

In the end, you only want to choose ONE of these approaches, and you should not need both. We typically use the G10 feature since that makes things a whole lot simpler for visualization purposes.

Hope that helps!

taerog
Posts: 11
Joined: Fri May 17, 2013 2:23 pm

Re: Makerbot 2x(Sailfish) Basic setup

Sun Jun 09, 2013 12:02 pm

Yup I boned that! Sorry!
The profile I uploaded Had both offsets! since I was playing with which to use.
In-fact I lost a bunch of tweaks because I forgot the (save) is only for the session and I need to export the profile to really save it! So what I sent out was a mash of whatever I was playing with at the time of exporting.

In the firmware I changed the heater gcode in the FW setting from m109 to m140 (do to how gpx responds to this and per Wingcommander's recommendations.)
reducing the wipe distance from -145 to below -135 was important. but that is just the beginning script.

Phgeis
Posts: 21
Joined: Tue Jun 04, 2013 7:32 am

Re: Makerbot 2x(Sailfish) Basic setup

Sun Jun 09, 2013 12:28 pm

Thanks for the explanation (Clayton I Think?)

And thanks for the claryfication taerog! Would you have the possibility to send your "cleaned" profile?

Phgeis
Posts: 21
Joined: Tue Jun 04, 2013 7:32 am

Re: Makerbot 2x(Sailfish) Basic setup

Sun Jun 09, 2013 12:53 pm

Still not shure which Bot axis config to use... Which axis has to be mirrored? just y or x and y?

taerog
Posts: 11
Joined: Fri May 17, 2013 2:23 pm

Re: Makerbot 2x(Sailfish) Basic setup

Sun Jun 09, 2013 2:37 pm

Do what He says above.
I found the new offset in the gcode (and used with GPX etc) works great. The "old" way with 1.1.2 works also but does not keep the object in the middle of the virtual build plate during simulation so the "new" way seems better if not only by way of looks during sim.
Though it may not work if you pull the gcode and render the x3g with repg as I did with v1.1.2 for a time . . GPX seems to fix some of the codes?

Also I am not sure what you meant by flipping x or y? all I needed to do was move the origin.

Sure I will upload another after I insure it works and then export it! :) Really there is not much to change from the default rep2 one they have . . Just a fix for the HBP and wipe instructions for the 2x (the x is too far) boost the temp and minor things like that.

Phgeis
Posts: 21
Joined: Tue Jun 04, 2013 7:32 am

Re: Makerbot 2x(Sailfish) Basic setup

Sun Jun 09, 2013 5:02 pm

Now, taken care about the offset the build is where i should be, but the first move goes straight of the build plate. even with the "standard" rep 2 profile this happens.
Attachments
1.jpg
1.jpg (36.75 KiB) Viewed 8974 times

Return to “Troubleshooting and Bug Reports”