falken
Posts: 19
Joined: Fri Jun 07, 2013 11:05 pm

Why won't Simplify3d 2.2.2 work on my Dreamer?

Thu Feb 19, 2015 3:20 pm

This software works great on my Replicator 2, but I can't get it to work on my dreamer. I have to go in and edit the g code so it won't tell the bot to turn the extruder heater off right after it sets the temp. Then it doesn't extrude anything when it starts the print. I think the stepper motor isn't even turning on. I don't understand gcode, so I just looked at it. Here is a copy of some of it from my file that I'm trying to fit. Please note that I am using the left extruder and it does heat up as per the LCD screen on the left side despite the comments that are in the gcode getting the tools mixed up.

Is there anything in this code that is not telling the extruder stepper motor to turn on? I don't really know what I'm looking at.

; **** FlashForge Dreamer start.gcode for ABS ****
M140 S105 ; Set the current built plate temperature
M104 S220 T1 ; Set the right extruder temperature
M104 S0 T0 ; Set the left extruder temperature
G28 ; home all axes
M132 X Y Z A B ; recall home offsets
G1 Z100 F3300 ; ? home Z?
G1 X-110.5 Y-74 F6000 ; ? home XY?
M7 ; ? coolant A on (flood coolant)?
;M6 T0 ; wait for toolhead 0 and HBP to reach temperature
M6 T1 ; wait for toolhead 1 and HBP to reach temperature
; Note that in the next line A = Right Tool
; B = Left Tool
; 100 = ABS
; 80 = PLA
; 20 = NOT USED
; What is this for? The extruder spetmoter power?
; It's probably the fan speed
; 100 = full speed.
M907 X100 Y100 Z40 A20 B100 ; ? Set digital trimpot motor current using axis codes ????
G1 Z0.6 F3300 ; Move to Z 0.6
; set feed rate to 3300
G4 P2000 ; ? Dwel P?
M106 ; Fan On
M108 T1 ; We always default to tool head 0
G1 E-1 F1200
G1 Z0.18 F1200
; layer 1, Z = 0.18
M108 T0
M135 T0



Thank you

JoeJ
Posts: 1436
Joined: Sun Feb 16, 2014 10:52 am

Re: Why won't Simplify3d 2.2.2 work on my Dreamer?

Thu Feb 19, 2015 5:01 pm

Have you tried using the stock dreamer profile? There are quite a few specialty commands that are not one-to-one between the Dreamer and the Rep2.

Try this, go to Help --> Config Assistant, and pick the Dreamer profile. Then slice the part and try printing over USB. Does that work correctly? If so, then you probably just have an issue with your custom dreamer profile that you created. For reference, using the stock profile works fine on my printer.

falken
Posts: 19
Joined: Fri Jun 07, 2013 11:05 pm

Re: Why won't Simplify3d 2.2.2 work on my Dreamer?

Thu Feb 19, 2015 5:24 pm

Thanks for the quick reply. I bought Simplify3d way back in version 1.something. It didn't have a dreamer profile when I bought it and when I got the dreamer there were no profiles for it. I found these custom profiles on this forum somewhere. I have since updated to version 2.2.2 and I do not have any entries named "Dreamer". The only dreamer profiles I have are the three I found on the forum when I was trying to get it working the first time. Is there a profile that works that I can download? I don't know why it didn't install it when I updated unless it's because I didn't uninstall the previous version first...

The only things under flashforge are bunch of Creator Dual profiles and a creator single profile.

falken
Posts: 19
Joined: Fri Jun 07, 2013 11:05 pm

Re: Why won't Simplify3d 2.2.2 work on my Dreamer?

Thu Feb 19, 2015 5:26 pm

Oh, I'm sorry, I see you told me to go to help to get there, I was looking in profiles. Thank you I didn't even know this existed. I'll see if this works now. Thanks.

falken
Posts: 19
Joined: Fri Jun 07, 2013 11:05 pm

Re: Why won't Simplify3d 2.2.2 work on my Dreamer?

Thu Feb 19, 2015 5:52 pm

Ok that seemed to give me a better profile and I was able to set up the left extruder. Perhaps this is a setting I'm missing, but I'm trying to get it to print at 220 c with a bed temp of 105. It heats the bed just fine, then when it goes to heat the extruders, it starts printing way before they even get hot, it gets to aprox 78 c then everything starts moving as though it reached 220. is there a setting I'm missing that is causing this?

falken
Posts: 19
Joined: Fri Jun 07, 2013 11:05 pm

Re: Why won't Simplify3d 2.2.2 work on my Dreamer?

Thu Feb 19, 2015 6:05 pm

No I tried preheating the machine before starting the print and that got the temps to stay, but it is not extruding plastic again, I don't understand this at all. Has there been any firmware updates for the bot? I have not updated the firmware at all, it has not been connected to a computer and is not near one at the moment. If there's been a firmware update, maybe that's why it's not working.

JoeJ
Posts: 1436
Joined: Sun Feb 16, 2014 10:52 am

Re: Why won't Simplify3d 2.2.2 work on my Dreamer?

Fri Feb 20, 2015 6:21 am

I print with a dreamer all the time, so here's what I would recommend.

1) update the firmware on your Dreamer to the latest - there have definitely been changes, and many of them were very important ones!
2) go to Help --> reset all settings within S3D. This will reset the software to its factory state. Just be sure to save anything you need first ;)
3) after the reset, you will need to restart S3D. When it opens up, you will see the config assistant. Select the Dreamer and everything will be automatically configured.

After doing that, try a print without messing with any other settings. Make sure the stock settings work first before you start making changes.

User avatar
BaronWilliams
Posts: 159
Joined: Tue Jul 15, 2014 8:30 pm

Re: Why won't Simplify3d 2.2.2 work on my Dreamer?

Mon Feb 23, 2015 3:16 pm

If you upgraded, and you didn't reset, sometimes things don't quite work right.

I print all the time with the Dreamer using Simplify3D. Make sure your TOOL CHANGE G-CODE SCRIPT sets the tool. This wasn't need in some older versions of Simplify3D, but is now needed.

For the Dreamer the TOOL CHANGE G-CODE SCRIPT should be:

M108 T[new_tool]

If you don't see that there then something is wrong. I recommend resetting Simplify3D. And then setting it up for the Dreamer again.

Return to “Troubleshooting and Bug Reports”