justine
Posts: 4
Joined: Tue Jun 18, 2013 12:51 pm

Using Creator with Fablicator: Slow Arc Issue

Mon Jun 24, 2013 3:12 pm

Hello all,

I bought Creator for my personal M2 and after some tweaking am particularly pleased with the wonderful break-away support material (a vast improvement over what Slic3r does), the infill generation, and the ability to orient the part on the bed. I would love to see some improvements to the intuitiveness of the UI though: More than anything, I still find it confusing the way a process is saved. I miss Slic3r's simple drop-down box that lets me delete items from the list and doesn't clutter things with a whole directory address.

Anyway, we have a Fablicator where I work. Engineers, don't let the name scare you away. This seems to be a little-known printer (so far) but mechanically it's wonderful. We use it for mechanical prototyping as opposed to fabulous-type things, like industrial design (haha). I can't say enough good things about the rigidity, smoothness, and simplicity of the design, and it has a magical extruder that never ever drips and is always ready to go. No fiddling required and the bed is level from the factory and stays level. If I were to move up to anything from my M2 I would go with this (the M2 is fantastic at half the price of the Fablicator but the constant bed re-leveling and pre-print extruding to prime the nozzle gets tiring).

I tried generating gcode from Creator on my laptop to use on the Fablicator, because I thought in my mind "assuming there's no weird problems, it would be easy to justify another license". But, of course, weirdness had to happen. The problem is that any arc gets drawn extremely slowly and with a jerky movement, which seems to have been described by someone else here: http://www.forum.simplify3d.com/viewtop ... holes#p604

I tired turning the G2/G3 arc command option on and off as suggested in that thread, but there was no effect whatsoever. The problem isn't only that arcs are slow, but that they are in fact jerky. It's a bit strange to watch. If it didn't effect print quality it might still be usable on this printer, but it does effect print quality very much.

I assume there's a problem with how the Fablicator's firmware interprets the gcode, but it's not something that's ever happened with Slic3r's code. I should point out that the gcode is being printed through Pronterface (necessary being that the Fablicator is it's own computer).

I would love to get another Creator license for use at work, but not unless I can figure this out.

Anyone have thoughts?

~Justine Haupt

Simplify3D
Site Admin
Posts: 304
Joined: Sun Feb 10, 2013 8:28 pm

Re: Using Creator with Fablicator: Slow Arc Issue

Mon Jun 24, 2013 6:43 pm

Hey Justine,

I'd be happy to help you out with this. The software has some really impressive compatibility and we love helping people get it setup with new hardware systems! I've seen the Fablicator come up several times recently, but I'm actually surprised you have a physical product. I can't for the life of me find anyone who is actually selling it... But onto the more pressing issues, I have a feeling I know what the issue is that you're seeing. I'm going to send you an email with a bit more information.

PS - from the sound of it, I think you're going to like a few of the new features we already have included in our upcoming v1.1.4 software update ;)

justine
Posts: 4
Joined: Tue Jun 18, 2013 12:51 pm

Re: Using Creator with Fablicator: Slow Arc Issue

Tue Jun 25, 2013 9:45 am

Thank you very much. The Fablicator: Not obvious from the website at all, but if you contact the company (there's a sales email address), one can buy it that way. There was a bit of a lead time for ours though.

Return to “Troubleshooting and Bug Reports”