schlitt1968
Posts: 1
Joined: Sat Mar 07, 2015 8:29 pm

WARNING: CRC mismatch detected

Sun Mar 08, 2015 11:09 pm

WARNING: CRC mismatch detected
Testing alternate communication protocols...
RECEIVED: XZ@D
Attempting RTS reset and trying again...
Connection failed.

I am using the flash forge pro
and I cant connect via usb the simplify3d to the printer..Anyone seen this know whats up?

JoeJ
Posts: 1435
Joined: Sun Feb 16, 2014 10:52 am

Re: WARNING: CRC mismatch detected

Mon Mar 09, 2015 7:35 am

Hmm... never seen that before. What firmware did you put on there? I'm shocked to see any plain-text responses from what should be a binary-speaking machine

BigDaddio
Posts: 6
Joined: Mon May 05, 2014 9:25 pm

Re: WARNING: CRC mismatch detected

Sun Jul 19, 2015 9:40 am

OK yea this is weird I have been getting CRC mismatch with my FlashForge as well. It does however connect and work just fine. I may have been getting them all along I only noticed after I clicked off verbose communication. I am using sailfish couldn't say what version at the moment. I have not upgraded it in over a year. I really don't see a need to and it was a pita.

AndySimplify3D
Posts: 1
Joined: Mon Apr 14, 2014 3:22 pm

Re: WARNING: CRC mismatch detected

Sun Jul 19, 2015 4:47 pm

FWIW, I too just got this error with a new Delta - however it seems to come when Simplify 3.0 cannot connect fast enough to the RAMPS 1.3 - I disconnect and connect again and it connects perfect each time.
Using RAMPS 1.3 with Arduino Mega 2560, marlin latest...

I have a feeling it may be a USB issue of crosstalk or dodgy soldering on the USB port, or elsewhere on the board (its a "cheap" one!)

total a minor bug - I haven't tried printing once connected with this error, I've preferred to reconnect each time...
Andy
:-)

JATMN
Posts: 27
Joined: Mon Jul 13, 2015 12:09 pm
Location: Orange County, CA, USA
Contact: Website

Re: WARNING: CRC mismatch detected

Mon Jul 20, 2015 11:01 am

I haven't had CRC mismatch errors.. but I have had alot more communication issues with my Wanhao D4 than i did with 2.2 usually only resolve is to close S3D and turn off the printer then launch S3D and turn the printer back on.. usually have to do this 2-3 times before im able to print. I will try to post the console text next time.. but mine talks about plain text as well when its doing that..
Jack of All Trades Master of None
Wanhao Duplicator 4 (MFG 2013) + Simplify3D v3
Ultimaker v2 + Simplify3D v3
Ultimaker v2 - Aluminum - Remix By JAT.MN + Simplify3D v3

User avatar
meshbuilders
Posts: 1
Joined: Mon Aug 10, 2015 3:45 pm

Re: WARNING: CRC mismatch detected

Mon Aug 10, 2015 3:50 pm

Hi,

I just upgraded to Windows 10 and started having this issue connecting to my FlashForge Creator Pro.

This is the last few lines from the communication window:

SENT: d50115a2
WARNING: packet transmission failed, retrying... (d50115a2)
SENT: d50115a2
WARNING: packet transmission failed, retrying... (d50115a2)
SENT: d50115a2
SENT: d502860085
READ: 81d2d501808cd501808cd50181d2d50181d2d501808cd501808cd501808cd501808cd501808c
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
READ: d50181d2d501808cd50181d2d501808cd50181d201d580
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
READ: 8cd50181d2d50181d2d501808c
WARNING: CRC mismatch detected
WARNING: packet transmission failed, retrying... (d502860085)
SENT: d502860085
READ: d50181d2
SENT: d5030a0002d6
READ: d50381d400aa
SENT: d5030a010212
READ: d50381320075
SENT: d5030a001ee8
READ: d503815a0059
Disconnected.

As far as I know it is the most recent version of sailfish. I'm currently attempting to print and will double check once it either fails or finishes =)

alex_h
Posts: 1
Joined: Fri Sep 18, 2015 11:36 am

Re: WARNING: CRC mismatch detected

Fri Sep 18, 2015 11:39 am

I also have been getting the packet transmission failed since updating to windows 10 on my Sailfish Replicator 2. Has anyone any ideas about this?

JoeJ
Posts: 1435
Joined: Sun Feb 16, 2014 10:52 am

Re: WARNING: CRC mismatch detected

Sat Sep 19, 2015 4:43 am

There's many threads on this already. It's related to a bug in Windows 10 that affects some specific serial port drivers. Not much we can do except wait for a fix from microsoft (or downgrade back to Win7/8)

Rebekah_harper
Posts: 263
Joined: Wed Jan 21, 2015 10:25 am

Re: WARNING: CRC mismatch detected

Sat Sep 19, 2015 1:02 pm

hiya,

some may know some may not know. but the CRC is a Cyclic Redundancy Check as far as I know.

from what I understand is that the printer send a response to every command and it's this that causes the error.

I am running Sailfish 7.7 on a Wanhao D4S.

I get these errors every time. along with 'firmware version 0 detected' I have recently upgraded my HDD to SSD so I will give that a go to see if it's a speed thing on my set up. but I think it's a number of things.

Mainly the firmware on the printer as I was getting this on Win7 too. Without being able to see the full communications between the two I can't say exactly why but I'd like to think the Gods of S3D might come to some conclusion was to why it's occurring.

I have reported this a few times but I think it's got them stumped for the time being.

dvation
Posts: 15
Joined: Tue Jun 02, 2015 6:10 pm

Re: WARNING: CRC mismatch detected

Mon Sep 21, 2015 5:21 pm

For whatever it's worth I've been getting these errors on Win 8.1 since flashing Sailfish myself on my Monoprice 3D Printer (Flashforge Clone - same print board) . I emailed support and they ran me through the usual generic stuff (usb cable, whatever)...didn't help. I can still print okay over USB though for whatever reason.

Return to “Troubleshooting and Bug Reports”