Posts: 5
Joined: Mon Jun 17, 2013 2:34 pm

Error importing STL file incorrect binary format detected.

Fri Jun 28, 2013 9:43 pm

Hi All,
I can no longer import an STL.. Instead I get this message. "Error importing STL file. incorrect binary format detected." I had no problem with imports up to date, from both the thingiverse and from stls exported from Sketchup. After a sketchup STL fail I tried a thing averse file. This worked uploading the file once, but On a second try i can't reload the file with out getting this message. I have no problems opening these in RepG so I don't think that all of these STL files are suddenly corrupted.

I have uninstalled Creator, and then reinstalled it. No change. I have re exported Stetchup files, w no change.

Anyone have any clues?

Site Admin
Posts: 304
Joined: Sun Feb 10, 2013 8:28 pm

Re: Error importing STL file incorrect binary format detecte

Mon Jul 01, 2013 6:24 am

You can see a similar thread here (http://www.forum.simplify3d.com/viewtopic.php?f=8&t=116). This warning essentially means that the binary STL files does not adhere to the defined standards, which you can read more about on that thread. Our next update already has some more tolerant importing for these misbehaving files, but in the meantime, can you try exporting the STL in ASCII format and see if that imports correctly?

Return to “Troubleshooting and Bug Reports”