Page 1 of 2

[SOLVED] V3 tries to print with cold extruder

Posted: Wed Jul 08, 2015 5:10 pm
by Umpa
The HBP gets to temp. The extruder shows 30/230C and then it starts to print. If I pause the print (with heat pause) the extruder then heats up and I can unease and the print completes fine. Why is it trying to print before the the extruder heats up ?

Re: V3 tries to print with cold extruder

Posted: Thu Jul 09, 2015 1:34 am
by scobo
In the temperature tab, you need to select "wait for temperature controller to stabilise before beginning build".
I haven't checked your factory file but I'm guessing this is not checked in your settings.

Re: V3 tries to print with cold extruder

Posted: Thu Jul 09, 2015 2:21 am
by lithgowlights
I don't have that ticked and it waits. What I did have was the wrong extruded selected in one of the tabs. I'm on my phone so can't download your file to check, but could that be it?

Basically it was waiting for 0 degrees, seeing it and starting the print

Re: V3 tries to print with cold extruder

Posted: Thu Jul 09, 2015 2:45 am
by Umpa
Your right I don't have that selected - however I have never had that selected and it worked fine in v2.

Also The correct extruder is selected, it just fails to heat - however if I pause the print or pre-heat the extruder prior to print then its fine. If the wrong extruder was selected after 30 mins the nozzle would go cold ?

Re: V3 tries to print with cold extruder

Posted: Thu Jul 09, 2015 3:16 am
by lithgowlights
Yeah got home and downloaded your file and it all looked ok. I don't need that wait until stabilised ticked, but maybe you do with your machine? Worth a try at least

Re: V3 tries to print with cold extruder

Posted: Thu Jul 09, 2015 6:38 am
by JoeJ
Hmm. A lot of questions with your profile. First of all, you aren't using the firmware overrides, so I have no idea what firmware settings you have. It is also possible you have the wrong firmware configuration because you aren't using it. So I would suggest enabling that option on the G-Code tab. For now, I will assume you are using stock RepRap firmware configuration (but you should verify that too, cause if you have that wrong, that would explain why it isn't heating)

When I slice a model using your FFF profile and the RepRap firmware configuration, here's the first few lines of the file that I see.

Code: Select all

M106 S0
M104 S190 T0
M109 S190 T0
G28 ; home all axes
That clearly has the M104 command to set the extruder temperature and then the M109 command which will wait for 190C to be reached before continuing the build. So I see nothing wrong with that (of course, it assumes you see those same exact lines in the start of your gcode file)

Re: V3 tries to print with cold extruder

Posted: Thu Jul 09, 2015 8:56 am
by Umpa
Hi yes I should mention I am using sailfish 7.7. My bot ignores all temps and goes with its own as I have Temp override on (in firmware). My printers are rep 1 clones.

Its not a problem, and it does not happen all the time. What I mean by that is, I slice with the same process all the time, sometimes it creates the .x3g file and it prints perfect - other times I slice with it - it fails to engage the heaters (but will hold the temp and print if pre-heated).

I never has this with 2.x - but the other improvements out way this little annoyance I have. I just wondered if anyone else sees this.

Re: V3 tries to print with cold extruder

Posted: Thu Jul 09, 2015 9:38 am
by JoeJ
if your printer is a Rep1 clone, then you definitely have some problems. The profile you posted has many things wrong for that type of printer including the starting script.

I'm not sure why you're trying to use that profile, but I would strongly recommend using the stock Replicator 1 Dual profile from the S3D configuration assistant instead. That's going to be much easier than fixing all of the problems with this profile. Then just go to the starting script and comment out the 4 or 5 lines that do temperature control. Everything is already labeled quite well, so it should be quite easy to read through it and comment out the stuff you don't need.

Note: when you do something like commenting out the "M104 S[extruder0_temperature] T0" line, be sure to actually comment it out. Don't remove it. It will cause other problems if you remove it entirely.

Re: V3 tries to print with cold extruder

Posted: Fri Jul 10, 2015 3:24 pm
by billyd
Yeah mine used to wait until the bed and extruder were up to temperature before homing the bed (and then going on to prime and print).

With V3, it homes the bed (after the bed is up to temp) and moves the nozzle into the priming position, then waits for the extruder to get to temp and then prints. So they fiddled with the startup codes I guess.

Re: V3 tries to print with cold extruder

Posted: Sat Jul 11, 2015 8:42 am
by Umpa
Guys - just to let you know I have fixed it and what the problem was.

Version 3 allows you to choose which extruder does what - from purge to infill etc. Although I was on the Left Extruder settings the drop down box had the right extruder set. Hence it only affected the left extruder, which I mistook for it doing it some times and not others.

Just thought I would give closure.