DaveA
Posts: 7
Joined: Tue Mar 22, 2016 5:26 pm

Re: Windows 10 USB Connection Question

Tue Apr 26, 2016 7:23 am

I normally run OctoPrint so I haven't run into the USB issues in a while but yesterday I was making some printer changes and wanted to run S3D direct.
In 4 out of 5 prints the communications did hang requiring a Forced Next. The interesting thing to me was that the hang was exactly in the same place in the print. As soon as the bed heating finished and was about to turn on the extruder heat is when things stopped. Once I did the force next the print continued with no problem. The longest print was about 2 hours. This is telling me something here but I'm not sure what.

This is on the latest Windows 10 preview build with a FolgerTech Prusa I3 reprap printer running USB through a front panel hub. The printer is running the latest RC5 version of Marlin. OctoPrint doesn't seems to have this hang sending the same gcode to the printer.

It just seems to me if we have some random USB problem it wouldn't be happening at the same place in 4 out of 5 of my prints.

CompoundCarl
Posts: 2005
Joined: Wed Aug 05, 2015 7:23 am

Re: Windows 10 USB Connection Question

Wed Apr 27, 2016 5:58 am

DaveA wrote:I normally run OctoPrint so I haven't run into the USB issues in a while but yesterday I was making some printer changes and wanted to run S3D direct.
In 4 out of 5 prints the communications did hang requiring a Forced Next. The interesting thing to me was that the hang was exactly in the same place in the print. As soon as the bed heating finished and was about to turn on the extruder heat is when things stopped. Once I did the force next the print continued with no problem. The longest print was about 2 hours. This is telling me something here but I'm not sure what.
I would probably make a new thread for this issue, since it's likely different than what's being discussed here. If it's stopping at the same place during the preheat routine, it's not the same behavior as what this thread is about. When you make the new thread, include your communication log and I'm sure someone will be able to help.

jtwhissel
Posts: 1
Joined: Tue May 03, 2016 4:58 pm

Re: Windows 10 USB Connection Question

Tue May 03, 2016 5:00 pm

dtmarshall wrote:Not sure I'm buying this. Everything was working fine for me with MatterControl, the only thing I changed was getting Simplify3d.
Ditto, MatterControl on windows 10 never freezes or stops. Even on 24 hour + prints. Robo 3d +

dklassen
Posts: 25
Joined: Fri Jul 04, 2014 11:12 am

Re: Windows 10 USB Connection Question

Fri May 06, 2016 9:54 am

Simplify3D, what say you??

ldsanders
Posts: 2
Joined: Thu Dec 17, 2015 10:07 am

Re: Windows 10 USB Connection Question

Sun May 08, 2016 10:34 pm

It seems to me that my experience printing thru MatterControl always works on Windows 10. And, S3D almost always randomly stops. The S3d communication window displays "Firmware unresponsive Attempting to force continue". Sometimes clicking pause/resume works. Other times you have to wait for it start itself. Problem with that is the filament will ooze out of the nozzle if it takes too long and then you have a bad layer run until it the nozzle is primed again. I've tried all the USB updates, turning off all sleep modes, different cables. None of this helps.

User avatar
dkightley
Posts: 2164
Joined: Tue Mar 10, 2015 4:09 pm

Re: Windows 10 USB Connection Question

Mon May 09, 2016 8:59 am

I have to admit that I'm coming round to the way of thinking that this is a bug in S3D...and not a Windows 10 issue.

With that probably being the case, we have Simplify3D having the opinion that it's a Microsoft issue and not an issue in the code....and hence they're waiting for Microsoft to come up with a fix, and Microsoft not intending to investigate because only one application is affected and therefore it's an application issue, and we're now sitting at a stalemate situation where sod all is likely to happen.....ever!
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

dklassen
Posts: 25
Joined: Fri Jul 04, 2014 11:12 am

Re: Windows 10 USB Connection Question

Mon May 09, 2016 6:39 pm

It's a real pickle. I have to spin up Octoprint to get around it and I hate using it.

User avatar
jimc
Posts: 1124
Joined: Wed Aug 28, 2013 11:02 pm
Location: mullica, nj
Contact: Website

Re: Windows 10 USB Connection Question

Sun Jun 05, 2016 6:51 pm

might be too soon to tell but has anyone seen this problem go away recently? wondering if a windows update corrected the issue or not. my printer would freeze like clockwork every single print over usb. i never once not had it lock up and recently i gave it another shot and usb worked like a charm. i tried again and it worked again. been through 4 different prints now and all is working ok. anyone else still seeing it?

User avatar
dkightley
Posts: 2164
Joined: Tue Mar 10, 2015 4:09 pm

Re: Windows 10 USB Connection Question

Sun Jun 05, 2016 7:04 pm

This is one of those things that you don't want to be the first to dice with potential failure when you're used to doing something one way...even if that way is somewhat inconvenient.

I stopped using USB several months ago and transferred to using SD cards....something I've now got used to....and I've even reassigned the USB cable; it's now connecting a 3D cutter to my PC. And I've now got a second printer that is located not only in a separate room...but it's upstairs, so I force myself to get some exercise now and again when dashing from PC to printer...or even printer to printer (to get the one tool I have for prising prints off the bed, etc).

So...to answer your question....No, I've not tried USB comms again....and with things having gone quiet I'm not sure if it's because the issue has been fixed....or everyone (like me) has now got used to using other means. Perhaps it now may be time to bite the bullet and give USB another go....for one of my printers that is. The other one will still contribute to trying to keep me fit!!
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

User avatar
jimc
Posts: 1124
Joined: Wed Aug 28, 2013 11:02 pm
Location: mullica, nj
Contact: Website

Re: Windows 10 USB Connection Question

Sun Jun 05, 2016 8:06 pm

yeah i hear ya doug. i am in the same boat. i just use sd all the time on my windows machine. once a month or so i usually like to give usb a try just to see if things were fixed. i got off of the preview builds of windows so i am running the current stable build that everyone else has. figured i would see if my results jived with everyone else.

Return to “Troubleshooting and Bug Reports”