inventabuild
Posts: 81
Joined: Sat Mar 19, 2016 12:29 pm

[FIXED] Perform retraction during wipe movement is broken

Sat Mar 19, 2016 12:55 pm

Perform retraction during wipe movment is broken in 3.0.2. With this feature checked S3D is way-over retracting. For example if I have Retraction Distance set to 4.5 mm, S3D will retract up to 8 mm with the actual retraction distance varying from retraction to retraction. Interestingly this feature is dependent on whether or not "Relative extrusion distances" is checked in the G-Code tab. If it's un-checked I get the excessive retraction just mentioned. If I check Relative extrusion distances then S3D way-over-extrudes.

No matter what I do "Perform retraction during wipe movement" is broken in 3.0.2.

CompoundCarl
Posts: 2005
Joined: Wed Aug 05, 2015 7:23 am

Re: Broken - Perform retraction during wipe movment

Sun Mar 20, 2016 10:39 am

Using relative extrusion distances works fine for me. I made a few test files and looked through the gcode and everything I can see is correct.

So if you're using relative extrusion distances and it's over-extruding, then you probably just need to lower your extrusion multiplier.

inventabuild
Posts: 81
Joined: Sat Mar 19, 2016 12:29 pm

Re: Broken - Perform retraction during wipe movment

Wed Mar 23, 2016 7:19 pm

Thanks for trying to help; however my extrusion multiplier is set to 0.9 and it prints beautifully when "Perform retraction during wipe movement" is turned off so I believe there is a bug in Simplify3D. I'm using Marlin firmware, which firmware are you using?

SimpleScott
Posts: 42
Joined: Tue Jan 12, 2016 7:23 pm

Re: Broken - Perform retraction during wipe movment

Wed Mar 23, 2016 10:41 pm

I agree, it is a bug in 3.0.2.

What solved it for me was changing the "Tool change retraction distance" to 0.00 on the Advanced tab. I first tried selecting the "Relative extrusion distances" option but that didn't help (apparently that doesn't work for all printers, despite some insisting it is the fix).

I could be wrong, but It appears to me the value in "Tool change retraction distance" is getting added to retracts when "Perform retraction during wipe movement" is enabled, even with a single extruder and no tool change. In any case, changing the "Tool change retraction distance" to 0.00 eliminated the problem for me.
Last edited by SimpleScott on Wed Mar 23, 2016 10:46 pm, edited 1 time in total.

User avatar
jimc
Posts: 1124
Joined: Wed Aug 28, 2013 11:02 pm
Location: mullica, nj
Contact: Website

Re: Broken - Perform retraction during wipe movment

Wed Mar 23, 2016 10:44 pm

with the relative extrusion checked it has always worked great for me as well. im using both mac and pc version on 3 different printers all running marlin. since that feature came out in 3.0 about a year ago you are the first person i have heard post about this problem. i have seen plenty of posts about the retractions being really long which the relative distance has cured for most people but ive never heard of heavy over extrusion.

inventabuild
Posts: 81
Joined: Sat Mar 19, 2016 12:29 pm

Re: Broken - Perform retraction during wipe movement

Sat Mar 26, 2016 12:44 pm

jimc wrote:with the relative extrusion checked it has always worked great for me as well. im using both mac and pc version on 3 different printers all running marlin. since that feature came out in 3.0 about a year ago you are the first person i have heard post about this problem. i have seen plenty of posts about the retractions being really long which the relative distance has cured for most people but ive never heard of heavy over extrusion.
Hi, I'm posting proof that "Perform retraction during wipe movment" is broken / over-extruding even with "Relative extrusion distances" checked.

Notice in the first picture the support around the snout of the dragon is a nice clean zigzag of dots with separation from the part as per my settings; whereas in the second picture the support forms over-extruded blobs around the snout with no separation from the part. The first picture with nice support structure is with "Perform retraction during wipe movment" off; whereas the second picture with the over-extruded blobby support structure is with "Perform retraction during wipe movment" on.

I also tried SimpleScott's suggestion of setting "Tool change retraction distance" to 0 and get the same results.

Hence, as my Subject mentions "Perform retraction during wipe movement" is broken whether "Relative extrusion distances" is checked or not.

I posted my G-code tab showing that "Relative extrusion distances" was checked throughout my testing. I will make a second post with my Advanced tab settings showing "Perform retraction during wipe" turned Off (used in the successful / first dragon picture) and On (used in failed / second dragon picture) because only 3 pics per post are allowed.
Off - Perform retraction during wipe.jpg
Off - Perform retraction during wipe - Successful print
On - Perform retraction during wipe.jpg
On - Perform retraction during wipe - Failed print
G-code tab - Relative extrusion distances - On.JPG
G-code tab
Last edited by inventabuild on Sat Mar 26, 2016 1:02 pm, edited 5 times in total.

inventabuild
Posts: 81
Joined: Sat Mar 19, 2016 12:29 pm

Re: Broken - Perform retraction during wipe movment

Sat Mar 26, 2016 12:47 pm

Post with my Advanced tab settings showing "Perform retraction during wipe" turned Off (used in the successful / first dragon picture above) and On (used in failed / second dragon picture above).
Advanced tab - Peform retraction during wipe - Off.JPG
Off - Perform retraction during wipe movement - Successful print
Advanced tab - Peform retraction during wipe - On.JPG
On - Perform retraction during wipe movement - Failed print

SimpleScott
Posts: 42
Joined: Tue Jan 12, 2016 7:23 pm

Re: Broken - Perform retraction during wipe movment

Sat Mar 26, 2016 1:00 pm

Just checking, did you try this specific combination?
* Gcode tab, "Relative extrusion distances" DISABLED (unchecked)
* Advanced tab, "Perform retraction during wipe movement" ENABLED (checked)
* Advanced tab, "Tool change retraction distance" 0.00MM

I ask because the image you posted still shows a Tool change retraction distance of 4.50mm.

That's the combination that worked around the problem for me. And I had EXACTLY the problem you described in your first post, i.e., crazy-long retractions whenever "Perform retraction during wipe movement" was checked.

The "Relative extrusion distances" had no effect for me, but setting "Tool change retraction distance" to 0.00mm eliminated the issue. Of course if you have multiple tool heads and need the tool change retraction distance, this may not be a practical solution.

There have been several threads on this excessive retraction problem, so I am hoping the next version of S3D will have a fix.

inventabuild
Posts: 81
Joined: Sat Mar 19, 2016 12:29 pm

Re: Broken - Perform retraction during wipe movment

Sun Mar 27, 2016 8:21 pm

SimpleScott,

You nailed it! I can get "Perform retraction during wipe movement" working with your workaround of:

* Gcode tab, "Relative extrusion distances" DISABLED (unchecked)
* Advanced tab, "Perform retraction during wipe movement" ENABLED (checked)
* Advanced tab, "Tool change retraction distance" 0.00MM

Now if I needed to have an extra long retraction on Tool Change then I'd be out of luck, but fortunately I don't need that with the Cyclops hot end. S3D needs to fix this. Too many people are wasting too much time and ruining prints trying to get it to work right. Even their tech service couldn't get it working right for me. They told me to turn on "Relative extrusion distances", but then the Support over-extrudes.

Thank you for the workaround!

inventabuild
Posts: 81
Joined: Sat Mar 19, 2016 12:29 pm

Re: Broken - Perform retraction during wipe movment

Wed Mar 30, 2016 7:35 pm

SimpleScott,

Actually "Perform retraction during wipe movement" is broken for the settings you gave me too...looks like I spoke too soon in my previous post.

I get terrible stringing on my part when I set "Tool change retraction distance" to 0. Interestingly if I give it the same value as "Retraction distance" in the Extruder tab (both 4.5 mm), then stringing goes away so it's not that I need extra retraction. Furthermore the stringing occurs during printing of the part with the active extruder not just during tool change which is weird.

Here's a pic showing really bad stringing with your settings:
* Gcode tab, "Relative extrusion distances" DISABLED (unchecked)
* Advanced tab, "Perform retraction during wipe movement" ENABLED (checked)
* Advanced tab, "Tool change retraction distance" 0.00MM
Strings Real Bad - Part During Build.jpg
Bad Strings During Build
Here's the other side of the prime pillar showing stringing is occurring on both extruders:
Strings Real Bad Fom Prime Pillar.jpg
Bad Stringing Prime Pillar
Here you can see bad strings running across the part during the first few layers of the build (ignore the one big string rising up in the picture...that's from raising the extruder):
Strings Real Bad - First Few Layers.jpg
Strings Bad First Few Layers
So "Perform retraction during wipe movement" is broken no matter which way you slice it.

Simplify3D should have fixed "Perform retraction during wipe movement" or notified people that it's broken...I've spent way too many hours trying to get it to work right because it's the only way to eliminate the bad seam that Simplify3D puts on my parts. Oh well, guess I'll have to wait till the next revision.

Return to “Troubleshooting and Bug Reports”