Posts: 5
Joined: Sun Mar 13, 2016 1:22 pm

Scale issue on import

Mon Mar 21, 2016 7:07 pm

I have read many threads here about importing and exporting stl files and scaling issues. None of them address what I am seeing.

I use 3D Studio Max and no matter what type of units I set it to when I import an OBJ it is always off scale. Clicking on the auto adjust scale option makes it worse. It seems to always assume everything I am importing is in inches no matter what and uses those inch measurements in millimeters.

To my knowledge OBJ format does retain scale. I don't know how Simplify3d reads this information.


These first tests were done with 1 cube where I kept changing the units of the scene and let the object stay the same size in relation to the unit type.

Export a 1 cm cube Imports as 1 mm cube

Export a 10 mm cube Imports as 1 mm cube

Export a .01 meter cube Imports as 1 mm cube (see a pattern here?)

Export a .394 inch cube Imports as 1 mm cube

Export a 1 generic unit cube Imports as 1 mm cube

Now I am messing with the scale of the object I export.

Export a 10 generic unit cube Imports as 10 mm cube

Export a 100 mm cube Imports as 10 mm cube

So it looks like it is just taking 3D Studio Max generic units and using those as mm no matter what. It isn't actually using the units the file is exported as. Is this behavior correct? It seems wrong. If I were to do this same experiment and import into Maya it will understand the unit differences. It will treat a obj exported at 10 mm and import it as 10 mm or 1 cm. What you would expect. Am I missing something? I looked all over for units setup or even an import export units settings. Nothing to be found. Any help would be great. I hate having to use generic units as mm to get Simplify3D to get the numbers right. It's wrong in all the other software packages I use.

Posts: 2005
Joined: Wed Aug 05, 2015 7:23 am

Re: Scale issue on import

Tue Mar 22, 2016 6:42 am

I don't think there are any units in STL and OBJ files - just numbers. So just change your software so that it exports everything in millimeter units, then you should be fine. That's the easiest solution at least :D

Posts: 2
Joined: Sun Mar 25, 2018 9:19 am

Re: Scale issue on import

Mon Apr 09, 2018 10:49 am

That does not solve the problem as mentioned above.
i have also tested this multiple times, no matter what scale i build my object to it is imported in mm, and has to be resized and that is frustrating. It works but if i wanted to build something exact I have to do a trial and error faze.
Building everything in mm doesn't solve the issue either, if i do that, then import, i get an error that my object is very small and must have been modelled in inches ,, asks me to resize the object, I've tried that for the heck of it and it doesn't scale to model either.
I also read that obj files stay the same shape when exported... so i have tried stl and obj files and it will not maintain size ratio.
I use maya, I thought the work around would be to use the "distance tool" and build exactly to scale,,, but still same thing when imported it is resized in mm a lot smaller than built at.

Posts: 2
Joined: Mon Jan 14, 2019 12:06 pm

Re: Scale issue on import

Mon Jan 14, 2019 12:11 pm

So, has there been found any solution for the described issue? I am having exactly the same problem as it written down here . . .

User avatar
Posts: 2206
Joined: Tue Mar 10, 2015 4:09 pm

Re: Scale issue on import

Mon Jan 14, 2019 2:16 pm

There is no "solution" to any issue!!

STL file do not hold any dimension information. A 1 cm cube saved in a CAD program will have a size of n UNITS x n UNITS x n UNITS in the STL. Where both the value n and whatever UNIT stands for will be based on what the CAD package exports the STL data as.

S3D, by default imports using UNITS of centimetres....so if a dimension of 1 UNIT comes in, then that dimension printed will be 1 cm. This can, of course, be varied using the scaling on import facility.

You need to configure the output of the CAD package and the customisable scaling on import into S3D so that what you get is the same size as it was designed.
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

Posts: 2
Joined: Mon Jan 14, 2019 12:06 pm

Re: Scale issue on import

Mon Jan 14, 2019 2:48 pm

Thanks alot, Doug. That solved it for me. Very good, short and clear explanation. Makes also sense in the end. ;-)

Posts: 4
Joined: Fri Dec 21, 2018 3:01 am
Location: Panama
Contact: ICQ Website AOL Skype

Scale issue on import

Wed Jan 16, 2019 9:44 am

Looks like the issue is in the exporting process when the source was a scala-based scale. Ill check it out.
<a href="https://www.noriualaus.com/sanyo-3-cup-rice-cooker/">https://www.noriualaus.com/</a>

Posts: 8
Joined: Sun Feb 03, 2019 1:59 pm

Re: Scale issue on import

Tue Feb 05, 2019 2:03 am

how would i go about fixing this myself i have inventor and autocad. not sure which is the problem i have both set for mm.

Return to “Troubleshooting and Bug Reports”