Page 1 of 1

Cocoon Create will not connect

Posted: Thu Jul 28, 2016 5:30 pm
by Billzilla
I'm having trouble getting my PC to connect with Simplify3D to the Cocoon Create printer.
Here's the dialogue from the connection screen.

Attempting connection at \\.\COM3...
Testing plaintext communication protocol...
Testing binary communication protocol...
READ: ¾!á?ûstart
READ: start
READ: Info:External Reset
READ: Info: 0.000000 0.000000 0.000000 0.000000 0.000000 0.000000 0.000000 0.000000 0.000000
READ: Free RAM:10732
Testing alternate communication protocols...
READ: SD init fail
READ: ok 0
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
READ:
READ: Resend:1
READ: ok
Attempting RTS reset and trying again...
READ:
READ: Resend:1
READ: ok
Connected to machine!
SENT: T0
READ: ok 0
READ: wait
SENT: M105
READ: ok 0
READ: T:22.01 /0 B:22.28 /0 B@:0 @:0
Connection failed.




Any ideas? This is with the second USB cable I've tried, it worked better than the first one and this cable is know to work okay with other devices. I'm happy to try another new cable if need be though.

Re: Cocoon Create will not connect

Posted: Fri Jul 29, 2016 7:21 am
by CompoundCarl
Try going to Tools > Firmware Configuration, Communication tab, and disabling the "wait for startup command" option.

Re: Cocoon Create will not connect

Posted: Fri Jul 29, 2016 11:34 pm
by Billzilla
CompoundCarl wrote:Try going to Tools > Firmware Configuration, Communication tab, and disabling the "wait for startup command" option.

It does connect now, (thanks!) but it still doesn't work properly.
S3D keeps sending M105 commands and I can turn on the extruder or platform heaters, but there's no temperature feedback nor can I then turn them off. Can't jog the X/Y/Z stuff at all.
I'll keep fiddling ...