72LSx
Posts: 4
Joined: Wed Oct 12, 2016 7:57 pm

Crashing Constantly on Process Update

Wed Oct 12, 2016 8:07 pm

This is my first post. I've been using Simplify3D for about a month with my Flashforge Creator Pro. Having used Stratasys software for the previous 4 years (for work) I would say this software has been very close to this as far as features go and has delivered great results.

It has been a great purchase up until now... The software constantly crashes whenever I click the "update profile" or "save as new" when configuring process settings. It has about a 20% success rate. I am outside of my 2 week trial otherwise I would return and try something else. Since I have been setting up my printer I am creating many test process setting profiles and this is becoming a severe headache with the crashing. Otherwise it hasn't crashed on slicing or prepping a model.

I am running a Dell M4600 business class laptop, Win 7 Pro OS, i7 quad core (2.8 ghz?), 16gb ram, and NVidia graphics cards. The thing can render and process heavy CAD use so Simplify3D should not be an issue.

Is anyone else having this issue? Any help directly from Simplify would be great.

Thanks

CompoundCarl
Posts: 2005
Joined: Wed Aug 05, 2015 7:23 am

Re: Crashing Constantly on Process Update

Thu Oct 13, 2016 7:01 am

I had this happen once when I accidentally copy/pasted some bad characters into the profile I was working with. So I'd say the easiest way to fix it is export any profiles you want to save by going to File > Export FFF Profile. Then go to Help > Reset All Settings to restore everything to the stock configuration. That will solve the crashing problem. Then you can re-import the profiles you saved previously (this may also help you identify the problematic one if it starts having trouble again after importing one specific file)

72LSx
Posts: 4
Joined: Wed Oct 12, 2016 7:57 pm

Re: Crashing Constantly on Process Update

Sat Oct 15, 2016 11:35 am

After clearing out some profiles the issue happens less, but is still there. If I don't "update profile" and just click OK and save it seems to save the process settings and not crash. Kind off odd it wants to crash due to a bad entry, you can only enter numeric characters anyways. Incase Simplify3D is trying to diagnose some of these issues I posted a crash report below. Tthank you for your responses.

Problem signature:
Problem Event Name: APPCRASH
Application Name: Simplify3D.exe
Application Version: 3.1.0.0
Application Timestamp: 5760635f
Fault Module Name: Qt5Core.dll
Fault Module Version: 5.3.2.0
Fault Module Timestamp: 5575e87d
Exception Code: c0000005
Exception Offset: 00000000000a8874
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: f4fb
Additional Information 2: f4fb8cd18d93f26b091305a49bb5f794
Additional Information 3: f0ea
Additional Information 4: f0ead96d40c80c0517c7d1d77796df79

Innovatorator
Posts: 12
Joined: Thu Feb 11, 2016 4:39 pm

Re: Crashing Constantly on Process Update

Thu Oct 27, 2016 1:21 pm

I'm having the same problem!

I had the problem previously, and I though it was due to me "forcing" a Dual Extrusion profile for my MAKEiT Pro. I reset all the settings and started over, did not use the dual extrusion wizard at all and, problem solved...

...or at least I though. Now it is doing it again, Process Setting dialog box crashing all the time. On this particular process is it happening changing First Layer Height and Width to 100 - no incorrect entries or anything funny.

It seems once it crashes once, it crashes ALL THE TIME, but always in Process Settings. Going to file another bug report.

Innovatorator
Posts: 12
Joined: Thu Feb 11, 2016 4:39 pm

Re: Crashing Constantly on Process Update

Thu Oct 27, 2016 1:33 pm

Also crashes when trying to export the FFF profile, so can't send it in with bug report let alone restore it after a reset.
It makes sense, corrupt file that cannot be updated cannot be exported either/

Last time I had to manually copy ALL the settings for the corrupted profiles then reset everything, then re-create the profiles manually. I really hope this doesn't become a monthly thing.

SusiT140V
Posts: 52
Joined: Sun Oct 30, 2016 5:12 pm

Re: Crashing Constantly on Process Update

Sat Nov 05, 2016 12:25 am

Getting the same issue.
A couple of days ago I bought the program, and within an hour I was getting the same crash!
For a first-time-user, I'm not impressed! This was a lot of cash to splash out to see this happen almost immediately. :cry:

A nice program, as far as I can see - when it does not crash. Not the best of impressions like I said... :(

CompoundCarl
Posts: 2005
Joined: Wed Aug 05, 2015 7:23 am

Re: Crashing Constantly on Process Update

Sat Nov 05, 2016 5:46 am

I can't say this has ever happened to me (and I have a LOT of profiles), but you might try going to Help > Reset All Settings to see if that solves it.

SusiT140V
Posts: 52
Joined: Sun Oct 30, 2016 5:12 pm

Re: Crashing Constantly on Process Update

Mon Oct 02, 2017 10:52 am

Am still getting this with the new version, only not quite as bad.

I did notice that not being logged-in improved the situation a little, but I really don't think this has any true connection, but is just an anecdotal/hopeful response by me.

I wonder if this could still be down to either of the following -

1. In the "Good Old, Bad Old Days", sometimes too much memory (RAM) could cause crashes due to poor memory management - this PC has 64GB.
How about you guys? Lots of memory in your S3D-crashing machines?

2. The crashes seem to happen whenever something is written to the Registry (Windoze) - I'm wondering if something is intercepting the Registry writes, such as Ccleaner, or SpyBot S&D, AV, etc.
Have just removed the first two, and going to see how that goes.
My AV is KasperskyTS, and although I had already stopped KTS messing with the S3D folders that have been scattered all over my PC, it is possible that KTS is still upsetting S3D with its grip on the Registry.

If removing the first two items actually improve things, I'll let you know.

Susi.

moggb
Posts: 5
Joined: Sat Apr 08, 2017 5:07 pm

Re: Crashing Constantly on Process Update

Tue Oct 17, 2017 7:11 am

i have too this problem :x
i find 4.0 really bugy :evil: anyway that not my principal problem now. because i'm still fighting with head1 offset issues on my creator pro :cry:
i succeed 2 weeks ago to make it works fine (it looks like a firmware update issue with flashforge one) sailfish looks like to work at tha time but now i'm having the same problem again. i had many profiles crash since. maybe it just spoil the config i dunno... but i'm quite fed up right now i have to say :?

(and sorry for bad english :oops: )

Ayres3D
Posts: 96
Joined: Mon Aug 14, 2017 1:15 pm

Re: Crashing Constantly on Process Update

Wed Oct 18, 2017 10:13 am

I've had this and managed to isolate it to when I'd managed to remove the infill or support angles and there was nothing set. Specifically, I had support angles set at +45/-45 and wanted to go back to 0. I removed the two 45s but got distracted and didn't add "0" back in.

S3D didn't like this :-/

NB - It might be helpful if S3D defaulted to 0 when there is nothing set.

Return to “Troubleshooting and Bug Reports”