MarkHargrove
Posts: 4
Joined: Sun Dec 11, 2016 1:25 am

Startup Gcode Script for FlashForge Creator Pro

Sun Dec 11, 2016 1:35 am

When I use the right extruder for the FFCP I get a good "purge and wipe" of the extruder head before it moves to begin the print.

The start gcode script for right extruder is:

; **** Replicator 1 dual start.gcode ****
M73 P0 ; enable build progress
G162 X Y F3000 ; home XY maximum
G161 Z F1200 ; home Z minimum
G92 Z-5 ; set Z to -5
G1 Z0 ; move Z to 0
G161 Z F100 ; home Z slowly
M132 X Y Z A B ; recall home offsets
M135 T0 ; load right extruder offsets
G1 X150 Y-70 Z30 F9000 ; move to wait position right hand side of the table
G130 X20 Y20 Z20 A20 B20 ; lower stepper Vrefs while heating
M126 S[fan_speed_pwm]
M140 S[bed0_temperature] T0
M134 T0 ; stabilize bed temperature
M104 S[extruder0_temperature] T0
M133 T0 ; stabilize right extruder temperature
G130 X127 Y127 Z40 A127 B127 ; default stepper Vrefs
G92 A0 B0 ; zero extruders
G1 Z0.4 ; position nozzle
G1 X110 Y-70 E25 F300 ; purge nozzle
G1 X120 Y-70 Z0.15 F1200 ; slow wipe
G1 X110 Y-70 Z0.5 F1200 ; lift

G92 A0 B0 ; zero extruders
M73 P1 ;@body (notify GPX body has started)
; **** end of start.gcode ****

When using the LEFT extruder, I get a puddled mess on the build table because the left extruder nozzle can't be moved off of right side of the build table. Instead, the 'purge' is done directly onto the build table and the 'wipe' is back and forth in the blob that was extruded as part of the purge. This almost always results in a stringy mess being drug into the start of the print.

Start gcode script for left extruder:

; **** Replicator 1 dual start.gcode ****
M73 P0 ; enable build progress
G162 X Y F3000 ; home XY maximum
G161 Z F1200 ; home Z minimum
G92 Z-5 ; set Z to -5
G1 Z0 ; move Z to 0
G161 Z F100 ; home Z slowly
M132 X Y Z A B ; recall home offsets
M135 T0 ; load right extruder offsets
G1 X150 Y-70 Z30 F9000 ; move to wait position right hand side of the table
G130 X20 Y20 Z20 A20 B20 ; lower stepper Vrefs while heating
M126 S[fan_speed_pwm]
M140 S[bed0_temperature] T0
M134 T0 ; stabilize bed temperature
M104 S[extruder1_temperature] T1
M133 T1 ; stabilize left extruder temperature
G130 X127 Y127 Z40 A127 B127 ; default stepper Vrefs
G92 A0 B0 ; zero extruders
G1 Z0.4 ; position nozzle
M135 T1 ; left tool
G1 X110 Y-70 E30 F300 ; move nozzle
G1 X120 Y-70 Z0.15 F1200 ; slow wipe
G1 X110 Y-70 Z0.5 F1200 ; lift

G92 A0 B0 ; zero extruders
M73 P1 ;@body (notify GPX body has started)
; **** end of start.gcode ****

Note that except for the tool change and the inexplicable E30 vs. E25 for the purge, both scripts move the extruder as if they had the same physical origin.

I'm way too much of a beginner to really be sure what I'm looking at though: am I understanding the gcode correctly?

Thanks!

-Mark

wirlybird
Posts: 1235
Joined: Sun Jul 17, 2016 1:32 pm

Re: Startup Gcode Script for FlashForge Creator Pro

Mon Dec 12, 2016 6:57 am

Search the forum for new scripts. Someone, and I forget who, recently posted new ones. If I can find it I will post.

User avatar
dkightley
Posts: 2170
Joined: Tue Mar 10, 2015 4:09 pm

Re: Startup Gcode Script for FlashForge Creator Pro

Mon Dec 12, 2016 7:02 am

Is this what you are looking for: viewtopic.php?f=8&t=6183&p=26817#p26817
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

MarkHargrove
Posts: 4
Joined: Sun Dec 11, 2016 1:25 am

Re: Startup Gcode Script for FlashForge Creator Pro

Mon Dec 12, 2016 11:42 am

I had searched for 'start script' but the author posted it as 'starting script' so I missed it. That was exactly what I was looking for -- thanks very much for remembering and posting a link for me!

Cheers,

-M.

wirlybird
Posts: 1235
Joined: Sun Jul 17, 2016 1:32 pm

Re: Startup Gcode Script for FlashForge Creator Pro

Mon Dec 12, 2016 12:44 pm

That's the one. I haven't tried it yet.

JamieLaing
Posts: 6
Joined: Fri Sep 19, 2014 7:15 pm

Re: Startup Gcode Script for FlashForge Creator Pro

Tue Dec 19, 2017 12:13 pm

Thanks so much, I'm looking forward to trying this out.

The FFCP encourages printing single colors using the left extruder. Unfortunately the default "Left Extruder Only" startup script is remarkably atrocious. Thanks for the link @dkightley!

User avatar
jrpmedia
Posts: 34
Joined: Sun Nov 02, 2014 12:36 pm
Location: UK
Contact: Website

Re: Startup Gcode Script for FlashForge Creator Pro

Wed Apr 04, 2018 9:08 am

G1 X-150 Y-70 Z30 F9000 ; move to wait position left hand side of the table

This seems to want to start in the middle of the bed?!

Any ideas as to why please?
IDM Imagineering
Professional Equipment for SuperHEROs.
https://www.idmimagineering.co.uk

rrdavis
Posts: 421
Joined: Sat Dec 09, 2017 4:52 am

Re: Startup Gcode Script for FlashForge Creator Pro

Thu Apr 05, 2018 7:08 am

Probably would have been best to make a new thread for this question...

but I would guess you have a problem with the offsets on the firmware. If you have the wrong offsets there, everything will print about 100mm to the left and 30mm towards the back.

wirlybird
Posts: 1235
Joined: Sun Jul 17, 2016 1:32 pm

Re: Startup Gcode Script for FlashForge Creator Pro

Thu Apr 05, 2018 7:43 am

What printer profile are you using for the Creator Pro?
If the firmware hasn't been modified then it is most likely fine.
You might try resetting S3D and reload the Creator Pro Profile. You could also get the start script from the QIDI Tech-1 profile. It is setup to do the prime lines rather than the extrude at the edge.

Return to “Troubleshooting and Bug Reports”