Page 1 of 3

Z hop/ retraction vertical lift at beginning of print

Posted: Wed Jan 11, 2017 3:05 pm
by Jgude
Hi Guys,

I have a problem with the retraction vertical lift. I would like to use this feature but what it does is a hop/vertical lift at the beginning (beginning of first layer) of the print resulting in a print mid air :S.

How can this happen and even better how can a resolve this?

Kind regards,

Johan

Re: Z hop/ retraction vertical lift at beginning of print

Posted: Thu Jan 12, 2017 4:55 am
by brian442
You should post a factory file and a screenshot of the move in the preview you are concerned with. That will make it easier to help!

Re: Z hop/ retraction vertical lift at beginning of print

Posted: Sun Jan 15, 2017 2:16 am
by Jasper
He means cura is using it and after home all the nozzle goes up and primes it. He probably wants to know how to prime the nozzle in S3D

Re: Z hop/ retraction vertical lift at beginning of print

Posted: Mon Feb 20, 2017 11:50 pm
by docmortal
I have the same problem and looking for a solution. Been making some nice prints and decided to enable "LIFT ON RETRACTION" I tried a .30 lift and what happens is on the very beginning of the first layer it will lift and not come back down... So first layer is in the air.

I had to disable this feature to get printing again.

Re: Z hop/ retraction vertical lift at beginning of print

Posted: Tue Feb 21, 2017 7:14 am
by brian442
Again, you need to post a factory file and some screenshots if you want help.

Re: Z hop/ retraction vertical lift at beginning of print

Posted: Tue Feb 21, 2017 9:16 am
by dkightley
Having read the reported issue, I'm hazarding a guess that the generic "it" is the printer as opposed to the slicer software,

That being the case, I'm surmising that with a large vertical movement, the vertical drive system on the printer may be having problems moving the required distance at the set speed....and the vertical registration is being lost, resulting in the resultant z position being too high.

If so, I would slow the z movement speed (Other tab in FFF settings) down to see if the resolution skipping goes away.

Re: Z hop/ retraction vertical lift at beginning of print

Posted: Wed Feb 22, 2017 5:59 pm
by docmortal
Thankyou for the suggestion !

I will try to lower z axis speed... I believe its set fast..

Whats funny is in the preview when i select layer ... The extruder tip is in the air to whatever mm setting i put in verticle lift..

When i preview in line i think its called the extrider tip in preview stays on the correct position...

Do you want me to post every single setting? Per page from the factory file?

Re: Z hop/ retraction vertical lift at beginning of print

Posted: Thu Feb 23, 2017 5:39 am
by brian442
Just go to File > Save Factory File, and then attach the .factory file here.

It may also help if you include a screenshot of the preview showing the exact area where you are having trouble.

Re: Z hop/ retraction vertical lift at beginning of print

Posted: Thu Feb 23, 2017 6:25 pm
by docmortal
I will do that once i get home from work.

So far I have even tried different firmware stock settings to see if there is any difference and the same thing. Preview in layer mode z goes up and doesnt come back down which reflects when i start a print with zlift on retraction enabled and it goes up to whatever mm I set but stays up.

Luckily i can still print nicely just have to disable zlift on retraction.

I slowed down z to like 5.0 from 16.7 and same issue.

Re: Z hop/ retraction vertical lift at beginning of print

Posted: Fri Feb 24, 2017 2:56 am
by docmortal
hope this will help troubleshoot. I also posted a pic of the extruder nozzle 5mm in the air during the whole print.