Page 1 of 1

Bed Leveling Wizard: Manual Enter Problem

Posted: Sat Mar 11, 2017 3:47 pm
by thingismith
Hello, just bought the S3d and am pretty happy with it so far...but it's like a gf, at first you're in love, but then you start seeing the flaws...

I just noticed the software doesn't have the "Software Print Leveling" that MatterControl has, found a previous mention of it here viewtopic.php?f=8&t=5828. It would be great to have for my bigger prints that need to be more precise.

So I want to adjust my screws (I have a Rostock Max v2) for height and want to set up the bed leveling wizard for my 3 towers. However, it seems that four points I have entered (0,90;77.94,-45;-77.94,-45; 0,0) are being interpreted as a Cartesian printer in the Wizard, and pulling my hotend to the far left/front. The options does show my printer as a Delta.

For the time being I can change the Macros in the Machine Control Panel, but as I have 4 points, I'd like a suggestion on how to fix this in the Wizard.

Re: Bed Leveling Wizard: Manual Enter Problem

Posted: Sun Mar 12, 2017 9:14 am
by Ohm
I'm in the exact same boat. And to give a little more detail, I have a 220 mm circular bed. I enter my build volume for X and Y as 220, and I enter the Origin Offset to be half of that for each (110). I entered coordinates into the manual positioning for bed leveling based on the G1 X/Y commands that get me near the screws with enough space to adjust things:
-56 / -72
59 / -47
8 / 78

That results in the bed leveling wizard sending the command:
SENT: G1 X-101.000 Y-117.000 Z10.100 F4800

Which is way off from what I was hoping for (G1 X-56 Y-72).

Where did we go wrong?

Re: Bed Leveling Wizard: Manual Enter Problem

Posted: Sun Mar 12, 2017 9:25 am
by Ohm
Correction - I realized my first mistake was using 220 instead of 220 * .707 (155.5)... but after plugging in 155.5 and 77.8 for my build volume and origin, the problem persists.