Mogal
Posts: 26
Joined: Mon Mar 20, 2017 12:55 pm

No communication with printer

Mon Mar 20, 2017 2:04 pm

Hello all first post!
JUST purchased, and not having a good start.

After an hour of searching, I have finally got the computer to connect to the printer.
It's connected, but none of the controls will control the printer. (Machine Control Panel)

Even though its connected, doesn't seem to be communicating.
(support videos didn't help any)

If I click 'begin printing over usb' the little printing progress bar pops up, but does no progress, printer doesn't move.

Windows 7(64bit)
Mendel90 with Marlin firmware

brian442
Posts: 1243
Joined: Mon Nov 28, 2016 5:35 am

Re: No communication with printer

Tue Mar 21, 2017 7:57 am

Did you check the Communication tab in the machine control panel to see what commands are getting sent back and forth?

Mogal
Posts: 26
Joined: Mon Mar 20, 2017 12:55 pm

Re: No communication with printer

Tue Mar 21, 2017 12:45 pm

Yes, there are commands going through - Although they are gibberish.
Been using repitier-host and everything works fine - So I know the system is working.
- Controlling printer manually, homing, sending files to print, and saving to SD card.

S3D says connected, but does nothing else.
No movement, no temp changes, no nothing.

Mogal
Posts: 26
Joined: Mon Mar 20, 2017 12:55 pm

Re: No communication with printer

Tue Mar 21, 2017 3:00 pm

Here is what I'm getting when I connect the printer with each piece of software.
So when one is working, and the other isn't like this, I have no idea what to look for?
RepetierHost.jpg
Simplify3D.jpg

brian442
Posts: 1243
Joined: Mon Nov 28, 2016 5:35 am

Re: No communication with printer

Wed Mar 22, 2017 7:58 am

Looks like you are using the wrong baud rate. Make sure you set the right rate in S3D. Yours might be 250000 or something else.

wirlybird
Posts: 1240
Joined: Sun Jul 17, 2016 1:32 pm

Re: No communication with printer

Wed Mar 22, 2017 9:17 am

Try a different rate but 115200 is pretty standard. What printer is selected in S3D? How are you connected with USB? Use a USB2 port, cable under 15 feet with no hubs, extensions etc.
The gibberish is the clue.

Mogal
Posts: 26
Joined: Mon Mar 20, 2017 12:55 pm

Re: No communication with printer

Wed Mar 22, 2017 9:36 am

Alright, I got it, my mistake.
I thought I hit 250, when I actually hit 230.
(Wont save my settings even after running as admin)
Should have double checked when all that gibberish text came out.

Made my first print last night.
Copied of some of my settings from slicer, and not too much change in print quality.
But it sure is much nicer to work in! Looking forward to this after a few more tweaks.

---

On another note, I cant seem to get the firmware updated.
(Maybe its the newer version of the arduino software?)
It wont compile, and throws errors everywhere.
(the last flash I ever did was back in 2014 - I saved the firmware folder and tucked it aside)
I wanted to tweak a few settings, but it wont compile now...
When I get more time I will post a couple of the errors.

Arduino Mega 2560 (Ramps 1.4)
Running Marlin (v1.0) Modded for a Mendel90.

Mogal
Posts: 26
Joined: Mon Mar 20, 2017 12:55 pm

Re: No communication with printer

Thu Mar 23, 2017 6:34 pm

Yup, had to revert back to Arduino 0022. All good and making progress!

I'm impressed so far with the improvements in prints... who woulda thought?! 8-)

Return to “Troubleshooting and Bug Reports”