migey
Posts: 8
Joined: Tue Apr 18, 2017 11:30 am

Profiles are disappearing, how about you?

Wed May 03, 2017 2:27 pm

Hello Guys,

So I have a very odd issue and I reported it to S3D but the response was not helpful at all.

S3D randomly deletes my profiles... it is very random and it is more like it reverts to previous version of my profiles.

Example one time I was making some changes to my profiles, I deleted a couple, added a new one and updated a couple. Everything was good no problems. Then when I came back the next day and created a new files it was back to before I made my changes. So the deleted ones came back, the new ones were gone...

This happens to me at least every couple days and its starting to drive me crazy because I'm currently in the process of trying to create profiles that work with my printer (another very frustrating process, which I won't get into on this topic).

So my question is, does anyone else have this issue?

I'm running the latest version of S3D.
I'm on a Mac
I have profiles with two different machines (another topic of discussion, not sure why there isn't an easier way to setup multiple machines)
I don't have an antivirus running (the only suggestion from S3D support)


I had such I hopes for this software and I'm starting to get pretty frustrated...

brian442
Posts: 1243
Joined: Mon Nov 28, 2016 5:35 am

Re: Profiles are disappearing, how about you?

Thu May 04, 2017 7:39 am

I can't say that this has ever happened to me on my Mac. Perhaps is related to permissions? That could prevent the software from being allowed to successfully save the profiles when it closes, so that when you re-open it, they wouldn't be there. But if that was the case, it should be pretty reproducible since it would happen every time you closed and re-opened the software. You made it sound like it works fine several times in a row, but has issues randomly in the future, so I'm not sure what would cause that...

wirlybird
Posts: 1235
Joined: Sun Jul 17, 2016 1:32 pm

Re: Profiles are disappearing, how about you?

Thu May 04, 2017 9:48 am

I have also seen similar things and am on Windows 7.
I'll open S3D and go to print another part in PETG for instance that I had printed the night before and my settings are gone. When I closed S3D I made sure to "update" the profile to save settings etc.
It almost seems like the software does some kind of update or reset behind the scenes and wipes out stuff.
It has happened on two separate installs.
It hasn't happened much but it is there.

User avatar
dkightley
Posts: 2167
Joined: Tue Mar 10, 2015 4:09 pm

Re: Profiles are disappearing, how about you?

Thu May 04, 2017 10:34 am

S3D randomly deletes my profiles... it is very random and it is more like it reverts to previous version of my profiles.
May I ask you confirm EXACTLY what you're saying here. Are you referring to profiles you would select to edit as listed as "Processes" on the preview view.....or are you referring to "Profiles" that you select for loading using the Select Profile dropdown in the FFF Settings pop-up window?

There is a difference.....and there's a simple explanation if you're referring to one of them as opposed to the other.
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

migey
Posts: 8
Joined: Tue Apr 18, 2017 11:30 am

Re: Profiles are disappearing, how about you?

Thu May 04, 2017 11:58 am

By "Profiles" I am referring to the drop down list in the "FFF Settings" dialog box when you "Edit a Process".

I'm going to give a detailed example.

1. Open S3D
2. Add a STL
3. Add a process and select a profile
4. Modify the profile (Sometimes I click the "Update Profile", sometimes I dont)
5. Print the model
6. Repeats steps 4 & 5 until I get the result I like. (Keep in mind there is often hours or even days during this process)
7. Click the "Save as New" button for the profiles
8. Sometimes I save the factory file, sometimes I dont
9. *Some time passes but computer stays on*
10. Come back to S3D (sometimes its closed and sometimes its still open)
11. Click "File > New"
12. Add a STL file
13. Add a Process
14. Then bam, the profile I saved in step 7 is no longer there and the changes I did in repeated steps 4 are reverted. Note, if I deleted any profiles during this time those would actually come back from the dead and show on the list again.

Things that dont seem to make a difference:
* If I leave S3D open or close it between jobs. I have had this issue by just coming back to an already open S3D window.
* If I click the "update profile" along the way
* If I do a file>new or just reopen a Factory File. Hell I've even had it just by coming back to a file I already had open (I'll explain this below)
* If I save a factory file or not


Alternate scenario:
There is one more scenario which is a little different.
* I do steps 1-6 as above
* I come back some time later
* I click "Edit Process"
* The process selected is now "Default" (the process was called sometime specific before)
* The "Default" process has all my changes from steps 4.
* The process that I was making changes to is now reverted.

This scenario is not as bad because the changes are still in the "Default" profile for some reason and can do a "Save as New" again to save my changes.


I'm a programmer by trade and don't report issues lightly. This is definitely an issue, perhaps its something specific to my machine but my machine is a pretty standard Mac setup.

My Mac:
OSX 10.10.5 (Yosemite)
iMac 27" i7 (mid 2010)
14 GB Ram
SSD HD (40GB Free space)
No Antivirus running

User avatar
dkightley
Posts: 2167
Joined: Tue Mar 10, 2015 4:09 pm

Re: Profiles are disappearing, how about you?

Thu May 04, 2017 2:58 pm

Aha!

I knew there'd be a simple explanation for you reported problem. And the answer is......

The "Preview mode" is a workspace...and anything loaded into it is transient data.....models, processes....these are held as if they are temporary data.

The confusing thing is that if you end a S3D session and then restart, whatever was loaded when you closed the software down is still there....but it is still temporary...or transient...data. Load a factory file.....and the transient data will be discarded if you're starting S3D...or you may get asked if you want to save the transient data as a factory file instead of junking it!

Bottom line....DO NOT rely on the Processes list as a store for your settings! ALWAYS save settings you want as a new Profile using the "Save as new" option on the FFF Settings page. They will be saved then so you can reload them by profile name. Read and understand this: https://www.simplify3d.com/support/arti ... ile-types/
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

migey
Posts: 8
Joined: Tue Apr 18, 2017 11:30 am

Re: Profiles are disappearing, how about you?

Thu May 04, 2017 4:59 pm

Thanks for the reply but I'm confused by your response.

That is exactly what I do in step #7. I click the "Save as New" in the FFF settings dialog. Which works and adds it to the list. However at a later time (seemingly randomly) it disappears from the list of profiles... and other profiles get reverted...

jpvonhemel
Posts: 8
Joined: Mon Aug 15, 2016 11:30 am

Re: Profiles are disappearing, how about you?

Mon Jun 26, 2017 10:51 am

I just reformatted my macbook pro and installed S3D fresh. It is losing FFF files that I've imported and it never did that in the past install or on my iMac. I also have issues on the MacbookPro where Edit Process Settings button stays grey and then opens when moused over, like it is stuck checked. Very odd behavior.

User avatar
SteveIsHeer
Posts: 48
Joined: Thu Sep 24, 2015 5:45 pm

Re: Profiles are disappearing, how about you?

Sat Aug 19, 2017 2:37 pm

I have a similar issue, every time I start S3D, the FFF process is completely gone. If I click ADD to add a new process, it usually adds the process with the same settings as I was previously using but not always. This is another example how tight security prevents the registry from being properly updated with the new process/profile settings. I really wish the settings were moved from registry storage to file storage. The registry, in my opinion, is not the place to store these settings, for one, the amount of data can become extremely large if you create multiple setting profiles and that just consumes way too much memory. The larger the registry, the slower the computer becomes. Secondly, it is much safer to examine and backup a text or xml file than going into the registry and since there is no confirmation of making a change within the registry, it is very easy to accidentally hit a key without knowing you hit it which then saves that wrong value when you exit regedit automatically without your knowledge.
Please consider changing the way profiles are stored and organized. This is one of my biggest pet peeves of this software. In order to have profiles that include ALL settings from the FFF settings window, we have been directed to add entries for the settings you want to preserve that are currently not automatically saved.
It show's to go you how feelish you fool when your tang is all tungled up and you bart stalking tackwards!

Snerkles
Posts: 3
Joined: Thu Jul 23, 2015 7:42 am

Re: Profiles are disappearing, how about you?

Sun Sep 03, 2017 2:23 pm

The same thing is happening to me. I set up a profile and then something seems to go wrong and my printer seems to have a brain fart. I go back adjust the settings again and again. It takes me several times before I can get the printer to do what I actually want it to do. One specific thing it does is that it won't autolevel. I don't change this setting unless I'm going to do two different colors but that's not very often. Yet, every time I go to print now the printer won't autolevel.

Return to “Troubleshooting and Bug Reports”